Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-16549

Remove Unsupported SSL/TLS Versions from Docs/Properties

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3.0
    • Fix Version/s: 3.3.0
    • Component/s: documentation, security
    • Labels:
      None

      Description

      We should remove the following unsupported versions from docs and core-default.xml appropriately.

      TLS v1.0
      TLS v1.1
      SSL v3
      SSLv2Hello

      ref:
      https://www.eclipse.org/jetty/documentation/9.3.27.v20190418/configuring-ssl.html
      https://github.com/eclipse/jetty.project/issues/866

      Akira Ajisaka, I happened to find you left TLSv1.1 in https://issues.apache.org/jira/browse/HADOOP-16000. Should we still keep it?

        Attachments

        1. HADOOP-16549.001.patch
          3 kB
          Daisuke Kobayashi

          Issue Links

            Activity

              People

              • Assignee:
                daisuke.kobayashi Daisuke Kobayashi
                Reporter:
                daisuke.kobayashi Daisuke Kobayashi
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: