Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-16219

[JDK8] Set minimum version of Hadoop 2 to JDK 8

    Details

    • Type: Improvement
    • Status: Patch Available
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.10.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Incompatible change

      Description

      Java 7 is long EOL; having branch-2 require it is simply making the release process a pain (we aren't building, testing, or releasing on java 7 JVMs any more, are we?).

      Staying on java 7 complicates backporting, JAR updates for CVEs (hello Guava!) &c are becoming impossible.

      Proposed: increment javac.version = 1.8

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                2 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated: