Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-15916

Upgrade Maven Surefire plugin to 3.0.0-M1

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.4, 3.3.0, 3.1.2, 3.2.1
    • Component/s: build
    • Labels:
      None

      Description

      Recently all the unit tests are failing. This is caused by the latest Java 8 issue reported at SUREFIRE-1588 and fixed in Maven Surefire plugin 3.0.0-M1. We need to update the plugin.

        Attachments

        1. HADOOP-15916.01.patch
          1.0 kB
          Akira Ajisaka
        2. HADOOP-15916.01-test.patch
          1 kB
          Akira Ajisaka

          Issue Links

            Activity

              People

              • Assignee:
                ajisakaa Akira Ajisaka
                Reporter:
                ajisakaa Akira Ajisaka
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: