Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-15617

Node.js and npm package loading in the Dockerfile failing on branch-2

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.3
    • Fix Version/s: 2.10.0, 2.9.3
    • Component/s: build
    • Labels:
      None

      Description

      RUN apt-get -y install nodejs && \
          ln -s /usr/bin/nodejs /usr/bin/node && \
          apt-get -y install npm && \
          npm install npm@latest -g && \
          npm install -g bower && \
          npm install -g ember-cli
      

      should get reduced to

      RUN apt-get -y install nodejs && \
          ln -s /usr/bin/nodejs /usr/bin/node && \
          apt-get -y install npm && \
          npm install npm@latest -g
      

      The locally installed versions of bower and ember-cli aren't being used anymore. Removing these cuts the docker build time significantly.

        Attachments

        1. HADOOP-15617-branch-2-003.patch
          0.9 kB
          Akhil PB
        2. HADOOP-15617-branch-2-002.patch
          0.8 kB
          Akhil PB
        3. HADOOP-15617-branch-2-001.patch
          0.6 kB
          Steve Loughran

          Issue Links

            Activity

              People

              • Assignee:
                akhilpb Akhil PB
                Reporter:
                aw Allen Wittenauer
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: