Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.1.0, 3.0.3
    • Component/s: fs/s3
    • Labels:
      None

      Description

      The latest versions of the AWS Shaded SDK are declaring a dependency on netty 4.1.17

      [INFO] +- org.apache.hadoop:hadoop-aws:jar:3.2.0-SNAPSHOT:compile
      [INFO] |  \- com.amazonaws:aws-java-sdk-bundle:jar:1.11.271:compile
      [INFO] |     +- io.netty:netty-codec-http:jar:4.1.17.Final:compile
      [INFO] |     +- io.netty:netty-codec:jar:4.1.17.Final:compile
      [INFO] |     +- io.netty:netty-handler:jar:4.1.17.Final:compile
      [INFO] |     +- io.netty:netty-buffer:jar:4.1.17.Final:compile
      [INFO] |     +- io.netty:netty-common:jar:4.1.17.Final:compile
      [INFO] |     +- io.netty:netty-transport:jar:4.1.17.Final:compile
      [INFO] |     \- io.netty:netty-resolver:jar:4.1.17.Final:compile
      

      We either exclude these or roll back HADOOP-15040.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: