Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-15261

Upgrade commons-io from 2.4 to 2.5

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha3
    • Fix Version/s: 3.1.0
    • Component/s: minikdc
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Hi, after analyzing hadoop-common-project\hadoop-minikdc\pom.xml, we found that Hadoop depends on org.apache.kerby:kerb-simplekdc 1.0.1, which transitivity introduced commons-io:2.5.
      At the same time, hadoop directly depends on a older version of commons-io:2.4. By further look into the source code, these two versions of commons-io have many different features. The dependency conflict problem brings high risks of "NotClassDefFoundError:" or "NoSuchMethodError" issues at runtime. Please notice this problem. Maybe upgrading commons-io from 2.4 to 2.5 is a good choice. Hope this report can help you. Thanks!

        Attachments

        1. 347.patch
          0.7 kB
          Akira Ajisaka
        2. hadoop.txt
          8 kB
          PandaMonkey

          Issue Links

            Activity

              People

              • Assignee:
                PandaMonkey PandaMonkey
                Reporter:
                PandaMonkey PandaMonkey
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: