Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-14317

KMSWebServer$deprecateEnv may leak secret

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha2
    • Fix Version/s: 3.0.0-alpha4
    • Component/s: kms, security
    • Labels:
      None

      Description

      May print warning message with secret in deprecated env var or matching property:

          LOG.warn("Environment variable {} = '{}' is deprecated and overriding"
                  + " property {} = '{}', please set the property in {} instead.",
              varName, value, propName, propValue, confFile);
      

        Attachments

        1. HADOOP-14317.001.patch
          1 kB
          John Zhuge
        2. HADOOP-14317.002.patch
          2 kB
          John Zhuge

          Issue Links

            Activity

              People

              • Assignee:
                jzhuge John Zhuge
                Reporter:
                jzhuge John Zhuge
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: