Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13942

Build failure due to errors of javadoc build in hadoop-azure

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0, 3.0.0-alpha2
    • Component/s: fs/azure
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      From HADOOP-13863, building javadoc of hadoop azure module failed.
      Though these error is not related to the patch of HADOOP-13868 directly, it can be fixed anyway.
      Building whole project fails with JDK "1.8.0_112".

      [WARNING] The requested profile "docs" could not be activated because it does not exist.
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:javadoc (default-cli) on project hadoop-azure: An error has occurred in JavaDocs report generation:
      [ERROR] Exit code: 1 - /testptch/hadoop/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeFileSystemStore.java:104: warning: no description for @throws
      [ERROR] * @throws IOException
      [ERROR] ^
      [ERROR] /testptch/hadoop/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeFileSystemStore.java:96: warning: no description for @throws
      [ERROR] * @throws IOException
      [ERROR] ^
      [ERROR] /testptch/hadoop/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeFileSystemStore.java:99: warning: no @param for prefix
      [ERROR] void purge(String prefix) throws IOException;
      [ERROR] ^
      [ERROR] /testptch/hadoop/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/KeyProvider.java:39: warning: no description for @throws
      

      ref: https://builds.apache.org/job/PreCommit-HADOOP-Build/11314/artifact/patchprocess/patch-javadoc-hadoop-tools_hadoop-azure.txt

      1. HADOOP-13942.01.patch
        15 kB
        Kai Sasaki
      2. HADOOP-13942.02.patch
        15 kB
        Kai Sasaki

        Issue Links

          Activity

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 13s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 12m 28s trunk passed
          +1 compile 0m 17s trunk passed
          +1 checkstyle 0m 13s trunk passed
          +1 mvnsite 0m 19s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 0m 25s trunk passed
          -1 javadoc 0m 13s hadoop-azure in trunk failed.
          +1 mvninstall 0m 15s the patch passed
          +1 compile 0m 15s the patch passed
          +1 javac 0m 15s the patch passed
          -0 checkstyle 0m 10s hadoop-tools/hadoop-azure: The patch generated 1 new + 19 unchanged - 0 fixed = 20 total (was 19)
          +1 mvnsite 0m 16s the patch passed
          +1 mvneclipse 0m 10s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 31s the patch passed
          -1 javadoc 0m 10s hadoop-tools_hadoop-azure generated 1 new + 0 unchanged - 33 fixed = 1 total (was 33)
          +1 unit 1m 21s hadoop-azure in the patch passed.
          +1 asflicense 0m 15s The patch does not generate ASF License warnings.
          19m 2s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Issue HADOOP-13942
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12844633/HADOOP-13942.01.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux af5f12f2dad1 3.13.0-103-generic #150-Ubuntu SMP Thu Nov 24 10:34:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / c721f78
          Default Java 1.8.0_111
          findbugs v3.0.0
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/11323/artifact/patchprocess/branch-javadoc-hadoop-tools_hadoop-azure.txt
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/11323/artifact/patchprocess/diff-checkstyle-hadoop-tools_hadoop-azure.txt
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/11323/artifact/patchprocess/diff-javadoc-javadoc-hadoop-tools_hadoop-azure.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/11323/testReport/
          modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/11323/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 15s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 14m 5s trunk passed
          +1 compile 0m 18s trunk passed
          +1 checkstyle 0m 12s trunk passed
          +1 mvnsite 0m 23s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 0m 31s trunk passed
          -1 javadoc 0m 16s hadoop-azure in trunk failed.
          +1 mvninstall 0m 18s the patch passed
          +1 compile 0m 17s the patch passed
          +1 javac 0m 17s the patch passed
          +1 checkstyle 0m 11s the patch passed
          +1 mvnsite 0m 19s the patch passed
          +1 mvneclipse 0m 11s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 36s the patch passed
          -1 javadoc 0m 13s hadoop-tools_hadoop-azure generated 1 new + 0 unchanged - 33 fixed = 1 total (was 33)
          +1 unit 1m 28s hadoop-azure in the patch passed.
          +1 asflicense 0m 17s The patch does not generate ASF License warnings.
          21m 25s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Issue HADOOP-13942
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12844637/HADOOP-13942.02.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 9ea1badd8a5b 3.13.0-103-generic #150-Ubuntu SMP Thu Nov 24 10:34:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / c721f78
          Default Java 1.8.0_111
          findbugs v3.0.0
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/11325/artifact/patchprocess/branch-javadoc-hadoop-tools_hadoop-azure.txt
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/11325/artifact/patchprocess/diff-javadoc-javadoc-hadoop-tools_hadoop-azure.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/11325/testReport/
          modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/11325/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          liuml07 Mingliang Liu added a comment -

          Thanks for providing a patch. I think this problem was reported HADOOP-13938 when we were working on HADOOP-13863. As HADOOP-13938 has no patch and it was unassigned, so I'll close that one marking as "duplicate" to this one.

          lewuathe Kai Sasaki added a comment -

          Mingliang Liu Sorry, I might overlook HADOOP-13938. Thanks for notifying!

          liuml07 Mingliang Liu added a comment -

          Dushyanth, would like to provide a review? Thanks,

          stevel@apache.org Steve Loughran added a comment -

          LGTM
          +1

          liuml07 Mingliang Liu added a comment -

          Kai Sasaki would like to have a look at the Jenkins complain about the javadoc? Other than that +1. Thanks,

          lewuathe Kai Sasaki added a comment -

          Mingliang Liu Javadoc complaints are the ones should be fixed with the attached patch. I confirmed these errors are fixed in local.
          I'm wondering why these error are kept thrown by Jenkins. Could you run Jenkins manually?

          liuml07 Mingliang Liu added a comment -

          I committed the patch to trunk and branch-2 branches. Thanks Steve Loughran for reviewing. Thanks Kai Sasaki for taking care of this. I tested locally and it passes without any problem.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11058 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11058/)
          HADOOP-13942. Build failure due to errors of javadoc build in (liuml07: rev c6a5b689db573046819f0e9193cb042e6c7298f4)

          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/metrics/AzureFileSystemInstrumentation.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/SelfRenewingLease.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeFileSystemStore.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/SASKeyGeneratorInterface.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/SendRequestIntercept.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/KeyProvider.java
          • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/StorageInterface.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11251 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11251/)
          HADOOP-13942. Update checkstyle and checkstyle plugin version to handle (aajisaka: rev 1e11080b7825a2d0bafce91432009f585b7b5d21)

          • (edit) hadoop-build-tools/src/main/resources/checkstyle/checkstyle.xml
          • (edit) pom.xml

            People

            • Assignee:
              lewuathe Kai Sasaki
              Reporter:
              lewuathe Kai Sasaki
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development