Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13675

Bug in return value for delete() calls in WASB

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.9.0, 3.0.0-alpha2
    • Component/s: fs/azure
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Current implementation of WASB does not correctly handle multiple threads/clients calling delete on the same file. The expected behavior in such scenarios is only one of the thread should delete the file and return true, while all other threads should receive false. However in the current implementation even though only one thread deletes the file, multiple clients incorrectly get "true" as the return from delete() call..

      1. HADOOP-13675.004.patch
        14 kB
        Dushyanth
      2. HADOOP-13675.003.patch
        14 kB
        Dushyanth
      3. HADOOP-13675.002.patch
        11 kB
        Dushyanth
      4. HADOOP-13675.001.patch
        9 kB
        Dushyanth

        Activity

        dchickabasapa Dushyanth added a comment -

        Adding first iteration of the patch to fix the return type handling for deletes.

        Testing: The patch contains new test to verify the changes made. Also changes have been tested against FileSystemContractLive tests for the both Block Blobs and Page Blobs.

        cnauroth Chris Nauroth added a comment -

        Hello Dushyanth. This patch basically looks good. A few comments:

        • Please do not subclass NativeAzureFileSystemBaseTest for the new test suite. This causes it to re-run every @Test from the base class, which adds ~5 minutes of redundant testing to the build. Instead, please subclass AbstractWasbTestBase. See HADOOP-13459 if you'd like more details on this.
        • I suspect pre-commit will show Checkstyle warnings in TestNativeAzureFileSystemConcurrencyLive. Please indent by 2 spaces. (Do not use tabs.)
        • After applying the patch, I saw test failures in TestNativeAzureFileSystemMocked,TestOutOfBandAzureBlobOperations and TestOutOfBandAzureBlobOperationsLive. Would you please investigate these and fix them?

        When posting patches, please run all tests, including the tests against the live Azure Storage service, and state that you ran all tests successfully before posting the patch. Thank you.

        jameeln Jameel Naina Mohamed added a comment - - edited

        Hi Chris Nauroth, Thanks for reviewing this patch.
        I have incorporated your comments.
        Reason for TestNativeAzureFileSystemMocked test failed was due to list api returned duplicated entries of files in a directory. I made the change to fix this issue. Now all tests are passing.
        I have a new patch witt the fix. Could you grant me access to upload patch to this jira?

        liuml07 Mingliang Liu added a comment -

        Hi Jameel Naina Mohamed, I have added you to the Hadoop Contributor on this site; and assigned this JIRA to you. Dushyanth please feel free to re-assign to yourself after Jameel uploads the new patch.

        dchickabasapa Dushyanth added a comment - - edited

        Mingliang Liu Thanks. I will be taking over the responsibility of uploading the second patch and addressing any issues for this Jira going forward. I have attached Hadoop-13675.002.patch that Jameel had worked on, kindly review the patch.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 14s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 1s trunk passed
        +1 compile 0m 17s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 21s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 0m 26s trunk passed
        +1 javadoc 0m 13s trunk passed
        +1 mvninstall 0m 15s the patch passed
        +1 compile 0m 14s the patch passed
        +1 javac 0m 14s the patch passed
        -0 checkstyle 0m 11s hadoop-tools/hadoop-azure: The patch generated 4 new + 43 unchanged - 0 fixed = 47 total (was 43)
        +1 mvnsite 0m 17s the patch passed
        +1 mvneclipse 0m 9s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 30s the patch passed
        +1 javadoc 0m 10s the patch passed
        +1 unit 1m 22s hadoop-azure in the patch passed.
        -1 asflicense 0m 15s The patch generated 1 ASF License warnings.
        13m 43s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue HADOOP-13675
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12840990/HADOOP-13675.002.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 2fbda7bed30b 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / aeecfa2
        Default Java 1.8.0_111
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/11163/artifact/patchprocess/diff-checkstyle-hadoop-tools_hadoop-azure.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/11163/testReport/
        asflicense https://builds.apache.org/job/PreCommit-HADOOP-Build/11163/artifact/patchprocess/patch-asflicense-problems.txt
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/11163/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        liuml07 Mingliang Liu added a comment - - edited

        Thanks for updating the patch. The main change looks good to me.

        1. Can you include the tests against the live Azure Storage service, and state that you ran all tests successfully before posting the patch?
        2. Can you explicitly write javadoc for the delete operation, especially the return value? What does it mean by deleting successful? Changes have been made because of this delete call?
        3. In test TestNativeAzureFileSystemConcurrencyLive, the reason of potential failure is lost. We can either log the encountered exception in child thread; or fail fast in the verification code, as example:
              boolean deleteSuccess = false;
              for (int i = 0; i < threadCount; i++) {
                assertFalse("child thread has exception", helperThreads[i].getExceptionEncounteredFlag());
                if (deleteSuccess) {
                  assertFalse("More than one thread delete() return true", helperThreads[i].getDeleteSuccess());
                } else {
                  deleteSuccess = helperThreads[i].getDeleteSuccess();
                }
              }
          

          replaces

          47	    boolean deleteSuccess = false, testSuccess = true;
          48	
          49	    for (int i = 0; i < threadCount; i++) {
          50	
          51	      if (helperThreads[i].getExceptionEncounteredFlag()) {
          52	        testSuccess = false;
          53	        break;
          54	      }
          55	
          56	      if (helperThreads[i].getDeleteSuccess()) {
          57	        if (deleteSuccess) {
          58	          testSuccess = false;
          59	          break;
          60	        } else {
          61	          deleteSuccess = true;
          62	        }
          63	      }
          64	    }
          65	
          66	    if (!deleteSuccess) {
          67	      testSuccess = false;
          68	    }
          69	    assertTrue(testSuccess);
          
        4. The checkstyle warnings are related. Please kindly fix.
        dchickabasapa Dushyanth added a comment -

        Thanks Mingliang Liu for the review. I have addressed your comments for the previous patch and attached Patch 3.

        Testing: The patch contains new test to verify the changes made. Also changes have been tested against live tests for the both Block Blobs and Page Blobs.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        -1 @author 0m 0s The patch appears to contain 1 @author tags which the community has agreed to not allow in code contributions.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 59s trunk passed
        +1 compile 0m 17s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 20s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 0m 25s trunk passed
        +1 javadoc 0m 12s trunk passed
        +1 mvninstall 0m 15s the patch passed
        +1 compile 0m 14s the patch passed
        +1 javac 0m 14s the patch passed
        -0 checkstyle 0m 11s hadoop-tools/hadoop-azure: The patch generated 5 new + 43 unchanged - 0 fixed = 48 total (was 43)
        +1 mvnsite 0m 17s the patch passed
        +1 mvneclipse 0m 10s the patch passed
        -1 whitespace 0m 0s The patch 5 line(s) with tabs.
        +1 findbugs 0m 30s the patch passed
        +1 javadoc 0m 10s the patch passed
        +1 unit 1m 20s hadoop-azure in the patch passed.
        +1 asflicense 0m 15s The patch does not generate ASF License warnings.
        13m 34s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue HADOOP-13675
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12841679/HADOOP-13675.003.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux b8c442e1c451 3.13.0-93-generic #140-Ubuntu SMP Mon Jul 18 21:21:05 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / f885160
        Default Java 1.8.0_111
        @author https://builds.apache.org/job/PreCommit-HADOOP-Build/11196/artifact/patchprocess/author-tags.txt
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/11196/artifact/patchprocess/diff-checkstyle-hadoop-tools_hadoop-azure.txt
        whitespace https://builds.apache.org/job/PreCommit-HADOOP-Build/11196/artifact/patchprocess/whitespace-tabs.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/11196/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/11196/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        dchickabasapa Dushyanth added a comment -

        Fixed checkstyle warnings from the previous patch.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 20s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 8m 41s trunk passed
        +1 compile 0m 22s trunk passed
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 25s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 30s trunk passed
        +1 javadoc 0m 14s trunk passed
        +1 mvninstall 0m 20s the patch passed
        +1 compile 0m 20s the patch passed
        +1 javac 0m 20s the patch passed
        +1 checkstyle 0m 14s the patch passed
        +1 mvnsite 0m 22s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 39s the patch passed
        +1 javadoc 0m 14s the patch passed
        +1 unit 1m 44s hadoop-azure in the patch passed.
        +1 asflicense 0m 20s The patch does not generate ASF License warnings.
        16m 50s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:a9ad5d6
        JIRA Issue HADOOP-13675
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12841697/HADOOP-13675.004.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 4b1c7d1bb1b7 3.13.0-93-generic #140-Ubuntu SMP Mon Jul 18 21:21:05 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / f885160
        Default Java 1.8.0_111
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/11197/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/11197/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        liuml07 Mingliang Liu added a comment -

        Committed to trunk and branch-2 branches. Thanks for your contribution Dushyanth and Jameel Naina Mohamed. Thanks Chris Nauroth for review.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10940 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10940/)
        HADOOP-13675. Bug in return value for delete() calls in WASB. (liuml07: rev 15dd1f3381069c5fdc6690e3ab1907a133ba14bf)

        • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • (add) hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestNativeAzureFileSystemConcurrencyLive.java
        • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/AzureNativeFileSystemStore.java
        • (edit) hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeFileSystemStore.java

          People

          • Assignee:
            dchickabasapa Dushyanth
            Reporter:
            dchickabasapa Dushyanth
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development