Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13125

FS Contract tests don't report FS initialization errors well

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      If the FileSystem.initialize() method of an FS fails with an IllegalArgumentException, the FS contract tests assume this is related to the URI syntax and raises a new exception 'invalid URI'+ fsURI, retaining the real cause only as error text in the nested exception.

      the exception text should be included in the message thrown, and cause changed to indicate that it's initialization related.

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9745 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9745/)
        HADOOP-13125 FS Contract tests don't report FS initialization errors (stevel: rev 35532614009652d2bca7ded72f166ef6b3382598)

        • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/contract/AbstractBondedFSContract.java
        stevel@apache.org Steve Loughran added a comment -

        thanks - committed.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 12s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 45s trunk passed
        +1 compile 5m 59s trunk passed with JDK v1.8.0_91
        +1 compile 6m 42s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 24s trunk passed
        +1 mvnsite 1m 0s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 34s trunk passed
        +1 javadoc 0m 54s trunk passed with JDK v1.8.0_91
        +1 javadoc 1m 7s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 41s the patch passed
        +1 compile 5m 57s the patch passed with JDK v1.8.0_91
        +1 javac 5m 57s the patch passed
        +1 compile 6m 46s the patch passed with JDK v1.7.0_95
        +1 javac 6m 46s the patch passed
        +1 checkstyle 0m 24s the patch passed
        +1 mvnsite 0m 55s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 50s the patch passed
        +1 javadoc 0m 53s the patch passed with JDK v1.8.0_91
        +1 javadoc 1m 3s the patch passed with JDK v1.7.0_95
        -1 unit 7m 13s hadoop-common in the patch failed with JDK v1.8.0_91.
        +1 unit 7m 48s hadoop-common in the patch passed with JDK v1.7.0_95.
        +1 asflicense 0m 23s The patch does not generate ASF License warnings.
        60m 8s



        Reason Tests
        JDK v1.8.0_91 Failed junit tests hadoop.net.TestDNS



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:cf2ee45
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12803282/HADOOP-13125-001.patch
        JIRA Issue HADOOP-13125
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux cd5961d77379 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6e56578
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_91 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/9364/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-HADOOP-Build/9364/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_91.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9364/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9364/console
        Powered by Apache Yetus 0.3.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        cnauroth Chris Nauroth added a comment -

        +1 pending pre-commit.

        stevel@apache.org Steve Loughran added a comment -

        a more helpful exception message

        stevel@apache.org Steve Loughran added a comment -

        after

        testReadNullBuffer(org.apache.hadoop.fs.contract.s3a.TestS3AContractSeek)  Time elapsed: 0.043 sec  <<< ERROR!
        java.io.IOException: Unable to initialize filesystem s3a://tests3neu/: java.lang.IllegalArgumentException: unknown signer type: AES256
        	at org.apache.hadoop.fs.contract.AbstractBondedFSContract.init(AbstractBondedFSContract.java:76)
        	at org.apache.hadoop.fs.contract.AbstractFSContractTestBase.setup(AbstractFSContractTestBase.java:165)
        	at org.apache.hadoop.fs.contract.AbstractContractSeekTest.setup(AbstractContractSeekTest.java:56)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:606)
        	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
        	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
        Caused by: java.lang.IllegalArgumentException: unknown signer type: AES256
        	at com.amazonaws.auth.SignerFactory.createSigner(SignerFactory.java:118)
        	at com.amazonaws.auth.SignerFactory.getSignerByTypeAndService(SignerFactory.java:95)
        	at com.amazonaws.AmazonWebServiceClient.computeSignerByServiceRegion(AmazonWebServiceClient.java:321)
        	at com.amazonaws.AmazonWebServiceClient.computeSignerByURI(AmazonWebServiceClient.java:294)
        	at com.amazonaws.AmazonWebServiceClient.setEndpoint(AmazonWebServiceClient.java:170)
        	at com.amazonaws.services.s3.AmazonS3Client.setEndpoint(AmazonS3Client.java:519)
        	at com.amazonaws.services.s3.AmazonS3Client.init(AmazonS3Client.java:492)
        	at com.amazonaws.services.s3.AmazonS3Client.<init>(AmazonS3Client.java:436)
        	at com.amazonaws.services.s3.AmazonS3Client.<init>(AmazonS3Client.java:416)
        	at org.apache.hadoop.fs.s3a.S3AFileSystem.initAmazonS3Client(S3AFileSystem.java:325)
        	at org.apache.hadoop.fs.s3a.S3AFileSystem.initialize(S3AFileSystem.java:221)
        	at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2785)
        	at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:99)
        	at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2822)
        	at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2804)
        	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:381)
        	at org.apache.hadoop.fs.contract.AbstractBondedFSContract.init(AbstractBondedFSContract.java:72)
        	at org.apache.hadoop.fs.contract.AbstractFSContractTestBase.setup(AbstractFSContractTestBase.java:165)
        	at org.apache.hadoop.fs.contract.AbstractContractSeekTest.setup(AbstractContractSeekTest.java:56)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:606)
        	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        
        
        stevel@apache.org Steve Loughran added a comment -

        Before

        testDeleteNonEmptyDirRecursive(org.apache.hadoop.fs.contract.s3a.TestS3AContractDelete)  Time elapsed: 0.03 sec  <<< ERROR!
        java.io.IOException: Invalid URI s3a://tests/
        	at org.apache.hadoop.fs.contract.AbstractBondedFSContract.init(AbstractBondedFSContract.java:76)
        	at org.apache.hadoop.fs.contract.AbstractFSContractTestBase.setup(AbstractFSContractTestBase.java:165)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:606)
        	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
        	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
        Caused by: java.lang.IllegalArgumentException: unknown signer type: AES256
        	at com.amazonaws.auth.SignerFactory.createSigner(SignerFactory.java:118)
        	at com.amazonaws.auth.SignerFactory.getSignerByTypeAndService(SignerFactory.java:95)
        	at com.amazonaws.AmazonWebServiceClient.computeSignerByServiceRegion(AmazonWebServiceClient.java:321)
        	at com.amazonaws.AmazonWebServiceClient.computeSignerByURI(AmazonWebServiceClient.java:294)
        	at com.amazonaws.AmazonWebServiceClient.setEndpoint(AmazonWebServiceClient.java:170)
        	at com.amazonaws.services.s3.AmazonS3Client.setEndpoint(AmazonS3Client.java:519)
        	at com.amazonaws.services.s3.AmazonS3Client.init(AmazonS3Client.java:492)
        	at com.amazonaws.services.s3.AmazonS3Client.<init>(AmazonS3Client.java:436)
        	at com.amazonaws.services.s3.AmazonS3Client.<init>(AmazonS3Client.java:416)
        	at org.apache.hadoop.fs.s3a.S3AFileSystem.initAmazonS3Client(S3AFileSystem.java:325)
        	at org.apache.hadoop.fs.s3a.S3AFileSystem.initialize(S3AFileSystem.java:221)
        	at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2785)
        	at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:99)
        	at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2822)
        	at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2804)
        	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:381)
        	at org.apache.hadoop.fs.contract.AbstractBondedFSContract.init(AbstractBondedFSContract.java:72)
        	at org.apache.hadoop.fs.contract.AbstractFSContractTestBase.setup(AbstractFSContractTestBase.java:165)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:606)
        	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
        	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
        

          People

          • Assignee:
            stevel@apache.org Steve Loughran
            Reporter:
            stevel@apache.org Steve Loughran
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development