Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      • hackage.haskell.org is pretty unreliable, switch to fpcomplete's mirror
      • quiet some of the output to make jenkins debugging easier
      • some other random fixes
      1. HADOOP-13067.00.patch
        5 kB
        Allen Wittenauer
      2. HADOOP-13067-branch-2.00.patch
        4 kB
        Akira Ajisaka

        Issue Links

          Activity

          ajisakaa Akira Ajisaka added a comment -

          Backported to branch-2 and branch-2.8. Thanks Andrew and Allen!

          andrew.wang Andrew Wang added a comment -

          Backport looks fine to me, +1 thanks Akira

          ajisakaa Akira Ajisaka added a comment -

          The test result looks good. I'll commit this tomorrow JST if there is no objection.
          cc: Andrew Wang

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 12m 43s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          0 mvndep 2m 13s Maven dependency ordering for branch
          0 mvndep 0m 16s Maven dependency ordering for patch
          +1 shellcheck 0m 7s There were no new shellcheck issues.
          +1 shelldocs 0m 8s There were no new shelldocs issues.
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 asflicense 0m 24s The patch does not generate ASF License warnings.
          16m 15s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:fb13ab0
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12812990/HADOOP-13067-branch-2.00.patch
          JIRA Issue HADOOP-13067
          Optional Tests asflicense shellcheck shelldocs
          uname Linux ffc4e2c77fc1 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision branch-2 / 8a1ee4d
          shellcheck v0.4.4
          modules C: U:
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9869/console
          Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          hadoopqa Hadoop QA added a comment -

          A patch to the testing environment has been detected.
          Re-executing against the patched versions to perform further tests.
          The console is at https://builds.apache.org/job/PreCommit-HADOOP-Build/9869/console in case of problems.

          ajisakaa Akira Ajisaka added a comment -

          Now we need to backport this to branch-2/2.8 because the docker build fails in branch-2.8, which is caused by HADOOP-13245.
          https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6584/console

          Step 16 : RUN pip install python-dateutil
           ---> Running in fff8a6f39370
          /bin/sh: 1: pip: not found
          The command '/bin/sh -c pip install python-dateutil' returned a non-zero code: 127
          
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9687 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9687/)
          HADOOP-13067. cleanup the dockerfile (aw: rev cf2ee45f71f3326c4b5b3367ef534c0277392fc1)

          • dev-support/docker/Dockerfile
          • dev-support/bin/create-release
          aw Allen Wittenauer added a comment -

          thanks for the review. committed to trunk

          ajisakaa Akira Ajisaka added a comment -

          LGTM, +1. I'm thinking we need to backport this to branch-2/2.8/2.7.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 16m 16s Docker mode activated.
          0 shelldocs 0m 5s Shelldocs was not available.
          +1 @author 0m 0s The patch does not contain any @author tags.
          0 mvndep 4m 37s Maven dependency ordering for branch
          0 mvndep 0m 23s Maven dependency ordering for patch
          +1 shellcheck 0m 14s There were no new shellcheck issues.
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 asflicense 0m 52s The patch does not generate ASF License warnings.
          22m 45s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:7b1c37a
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12801174/HADOOP-13067.00.patch
          JIRA Issue HADOOP-13067
          Optional Tests asflicense shellcheck shelldocs
          uname Linux a4f9036d5649 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 6f26b66
          shellcheck v0.4.3
          modules C: U:
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9215/console
          Powered by Apache Yetus 0.3.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          hadoopqa Hadoop QA added a comment -

          A patch to the testing environment has been detected.
          Re-executing against the patched versions to perform further tests.
          The console is at https://builds.apache.org/job/PreCommit-HADOOP-Build/9215/console in case of problems.

          aw Allen Wittenauer added a comment -

          -00:

          • fixes

            People

            • Assignee:
              aw Allen Wittenauer
              Reporter:
              aw Allen Wittenauer
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development