Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.7.2
    • Fix Version/s: 2.9.0, 3.0.0-alpha2
    • Component/s: build, fs/s3
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Incompatible change, Reviewed
    • Release Note:
      The dependency on the AWS SDK has been bumped to 1.11.45.

      Description

      HADOOP-13044 highlights that AWS SDK 10.6 —shipping in Hadoop 2.7+, doesn't work on open jdk >= 8u60, because a change in the JDK broke the version of Joda time that AWS uses.

      Fix, update the JDK. Though, that implies updating http components: HADOOP-12767.

        Attachments

        1. HADOOP-13050-branch-2-004.patch
          5 kB
          Steve Loughran
        2. HADOOP-13050-002.patch
          6 kB
          Mingliang Liu
        3. HADOOP-13050-branch-2-003.patch
          6 kB
          Steve Loughran
        4. HADOOP-13050-branch-2.003.patch
          6 kB
          Chris Nauroth
        5. HADOOP-13050-branch-2.002.patch
          2 kB
          Chris Nauroth
        6. HADOOP-13050-001.patch
          2 kB
          Steve Loughran

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                1 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: