Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha2
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    1. HADOOP-12974v7.patch
      6 kB
      Wei-Chiu Chuang
    2. HADOOP-12974v6.patch
      6 kB
      Wei-Chiu Chuang
    3. HADOOP-12974v5.patch
      7 kB
      Elliott Clark
    4. HADOOP-12974v4.patch
      7 kB
      Elliott Clark
    5. HADOOP-12974v3.patch
      7 kB
      Elliott Clark
    6. HADOOP-12974v2.patch
      7 kB
      Elliott Clark
    7. HADOOP-12974v1.patch
      3 kB
      Elliott Clark
    8. HADOOP-12974v0.patch
      4 kB
      Elliott Clark

      Issue Links

        Activity

        jojochuang Wei-Chiu Chuang added a comment -

        Committed it to trunk, branch-2 and branch-2.8. Thanks again Elliott Clark for the patch!

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10521 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10521/)
        HADOOP-12974. Create a CachingGetSpaceUsed implementation that uses df. (weichiu: rev 57aec2b46b0e46b73a1f49927e30e2c41138d535)

        • (add) hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestDFCachingGetSpaceUsed.java
        • (add) hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DFCachingGetSpaceUsed.java
        • (edit) hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/DU.java
        jojochuang Wei-Chiu Chuang added a comment -

        +1. Both test failures are not reproducible in my local tree.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 19s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 8m 30s trunk passed
        +1 compile 8m 18s trunk passed
        +1 checkstyle 0m 26s trunk passed
        +1 mvnsite 1m 3s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 38s trunk passed
        +1 javadoc 0m 51s trunk passed
        +1 mvninstall 0m 48s the patch passed
        +1 compile 8m 23s the patch passed
        +1 javac 8m 23s the patch passed
        +1 checkstyle 0m 25s the patch passed
        +1 mvnsite 1m 1s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 28s the patch passed
        +1 javadoc 0m 49s the patch passed
        -1 unit 16m 33s hadoop-common in the patch failed.
        +1 asflicense 0m 21s The patch does not generate ASF License warnings.
        52m 50s



        Reason Tests
        Failed junit tests hadoop.net.TestDNS
        Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Issue HADOOP-12974
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12830944/HADOOP-12974v7.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 57c583e18f3f 3.13.0-93-generic #140-Ubuntu SMP Mon Jul 18 21:21:05 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 236ac77
        Default Java 1.8.0_101
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/10631/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10631/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10631/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jojochuang Wei-Chiu Chuang added a comment -

        Post a v7 patch to fix checkstyle and added final keyword to the DF object.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 25s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 21s trunk passed
        +1 compile 7m 37s trunk passed
        +1 checkstyle 0m 25s trunk passed
        +1 mvnsite 1m 8s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 34s trunk passed
        +1 javadoc 0m 48s trunk passed
        +1 mvninstall 0m 43s the patch passed
        +1 compile 8m 34s the patch passed
        +1 javac 8m 34s the patch passed
        -0 checkstyle 0m 26s hadoop-common-project/hadoop-common: The patch generated 1 new + 0 unchanged - 0 fixed = 1 total (was 0)
        +1 mvnsite 0m 56s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 42s the patch passed
        +1 javadoc 0m 51s the patch passed
        +1 unit 8m 14s hadoop-common in the patch passed.
        +1 asflicense 0m 24s The patch does not generate ASF License warnings.
        43m 3s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Issue HADOOP-12974
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12830107/HADOOP-12974v6.patch
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux bb52a5853274 3.13.0-93-generic #140-Ubuntu SMP Mon Jul 18 21:21:05 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 6eb700e
        Default Java 1.8.0_101
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/10584/artifact/patchprocess/diff-checkstyle-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10584/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10584/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jojochuang Wei-Chiu Chuang added a comment -

        Thanks Elliott Clark for the patch. I reviewed it and I think it's almost ready. Here's my comment just for reference:

        • So DFCachingGetSpaceUsed doesn't really use unix df to get disk usage. Instead, it uses Java's File class API.
        • Also, the interval parameter is not used.
        • The DF object in DFCachingGetSpaceUsed can be made final.
        jojochuang Wei-Chiu Chuang added a comment -

        Post a new patch that fixed a small conflict in v5 patch.

        jojochuang Wei-Chiu Chuang added a comment -

        Hello Elliott Clark would you mind if I rebase it and make a small update to the patch you posted?
        Thanks!

        jojochuang Wei-Chiu Chuang added a comment -

        There's a small conflict due to jitter parameter introduced in HADOOP-12975.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        -1 patch 0m 5s HADOOP-12974 does not apply to trunk. Rebase required? Wrong Branch? See https://wiki.apache.org/hadoop/HowToContribute for help.



        Subsystem Report/Notes
        JIRA Issue HADOOP-12974
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12806708/HADOOP-12974v5.patch
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10499/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jojochuang Wei-Chiu Chuang added a comment -

        I'll review it in a day or two. Thanks a lot for working on this.

        eclark Elliott Clark added a comment -

        Ping?

        eclark Elliott Clark added a comment -

        Tests are un-related.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 12s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 56s trunk passed
        +1 compile 7m 19s trunk passed
        +1 checkstyle 0m 23s trunk passed
        +1 mvnsite 0m 58s trunk passed
        +1 mvneclipse 0m 11s trunk passed
        +1 findbugs 1m 23s trunk passed
        +1 javadoc 1m 0s trunk passed
        +1 mvninstall 0m 42s the patch passed
        +1 compile 7m 1s the patch passed
        +1 javac 7m 1s the patch passed
        +1 checkstyle 0m 24s the patch passed
        +1 mvnsite 0m 56s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 40s the patch passed
        +1 javadoc 0m 55s the patch passed
        -1 unit 17m 8s hadoop-common in the patch failed.
        +1 asflicense 0m 29s The patch does not generate ASF License warnings.
        48m 30s



        Reason Tests
        Failed junit tests hadoop.metrics2.impl.TestGangliaMetrics
        Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:2c91fd8
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12806708/HADOOP-12974v5.patch
        JIRA Issue HADOOP-12974
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux de2c9eb1cd39 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 5ea6fd8
        Default Java 1.8.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/9607/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common.txt
        unit test logs https://builds.apache.org/job/PreCommit-HADOOP-Build/9607/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9607/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9607/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 14s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 8m 9s trunk passed
        +1 compile 8m 0s trunk passed
        +1 checkstyle 0m 27s trunk passed
        +1 mvnsite 1m 6s trunk passed
        +1 mvneclipse 0m 11s trunk passed
        +1 findbugs 1m 45s trunk passed
        +1 javadoc 1m 3s trunk passed
        +1 mvninstall 0m 49s the patch passed
        +1 compile 7m 53s the patch passed
        +1 javac 7m 53s the patch passed
        -1 checkstyle 0m 24s hadoop-common-project/hadoop-common: The patch generated 2 new + 0 unchanged - 0 fixed = 2 total (was 0)
        +1 mvnsite 0m 56s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 32s the patch passed
        +1 javadoc 1m 6s the patch passed
        +1 unit 8m 34s hadoop-common in the patch passed.
        +1 asflicense 0m 26s The patch does not generate ASF License warnings.
        43m 35s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:2c91fd8
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12806686/HADOOP-12974v4.patch
        JIRA Issue HADOOP-12974
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 04be6cee3cf8 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 5ea6fd8
        Default Java 1.8.0_91
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/9606/artifact/patchprocess/diff-checkstyle-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9606/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9606/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        eclark Elliott Clark added a comment -

        I don't think you need to typecast the instance object.

        Only caching instances have a stop.

        walter.k.su Walter Su added a comment -

        1. DF constructor is DF(File path, long dfInterval)

        -    this.df = new DF(builder.getPath(), builder.getInitialUsed());
        +    this.df = new DF(builder.getPath(), builder.getInterval());
        

        2. About test. Current implementation of DF.java works on windows. And I think assertTrue(instance.getUsed() >= FILE_SIZE - 20); almost always true, since there's other files on the filesystem and other tests running. It's hard to create a mount point in the test, how about we verify that getUsed() is changing.

        jojochuang Wei-Chiu Chuang added a comment -

        Thanks Elliott Clark for the patch!
        I quickly went over the v3 patch, and it is looks good to me. A few minor issues:

        1. do not use wildcard import
          import static org.junit.Assert.*;
          
        1. in the test TestDFCachingGetSpaceUsed#testCanBuildRun, I don't think you need to typecast the instance object.
          ((DFCachingGetSpaceUsed)instance).close();
          
        eclark Elliott Clark added a comment -

        ping ?

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 10s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 30s trunk passed
        +1 compile 5m 55s trunk passed with JDK v1.8.0_77
        +1 compile 6m 40s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 20s trunk passed
        +1 mvnsite 0m 55s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 30s trunk passed
        +1 javadoc 0m 50s trunk passed with JDK v1.8.0_77
        +1 javadoc 1m 3s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 40s the patch passed
        +1 compile 5m 37s the patch passed with JDK v1.8.0_77
        +1 javac 5m 37s the patch passed
        +1 compile 6m 39s the patch passed with JDK v1.7.0_95
        +1 javac 6m 39s the patch passed
        +1 checkstyle 0m 19s the patch passed
        +1 mvnsite 0m 55s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 45s the patch passed
        +1 javadoc 0m 53s the patch passed with JDK v1.8.0_77
        +1 javadoc 1m 2s the patch passed with JDK v1.7.0_95
        +1 unit 7m 8s hadoop-common in the patch passed with JDK v1.8.0_77.
        +1 unit 7m 30s hadoop-common in the patch passed with JDK v1.7.0_95.
        +1 asflicense 0m 22s Patch does not generate ASF License warnings.
        58m 17s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12798775/HADOOP-12974v3.patch
        JIRA Issue HADOOP-12974
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux d6e2d969ba61 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / c970f1d
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9095/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9095/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        eclark Elliott Clark added a comment -

        Fixed the documentation to correctly describe how to use the class.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 11m 40s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 53s trunk passed
        +1 compile 6m 0s trunk passed with JDK v1.8.0_77
        +1 compile 6m 45s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 21s trunk passed
        +1 mvnsite 0m 57s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 35s trunk passed
        +1 javadoc 0m 51s trunk passed with JDK v1.8.0_77
        +1 javadoc 1m 4s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 41s the patch passed
        +1 compile 6m 5s the patch passed with JDK v1.8.0_77
        +1 javac 6m 5s the patch passed
        +1 compile 6m 47s the patch passed with JDK v1.7.0_95
        +1 javac 6m 47s the patch passed
        +1 checkstyle 0m 21s the patch passed
        +1 mvnsite 0m 55s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 50s the patch passed
        +1 javadoc 0m 53s the patch passed with JDK v1.8.0_77
        +1 javadoc 1m 4s the patch passed with JDK v1.7.0_95
        -1 unit 6m 49s hadoop-common in the patch failed with JDK v1.8.0_77.
        +1 unit 7m 10s hadoop-common in the patch passed with JDK v1.7.0_95.
        +1 asflicense 0m 23s Patch does not generate ASF License warnings.
        70m 38s



        Reason Tests
        JDK v1.8.0_77 Failed junit tests hadoop.ha.TestZKFailoverController



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12798595/HADOOP-12974v2.patch
        JIRA Issue HADOOP-12974
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux db2f68508288 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / e0cb426
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/9086/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_77.txt
        unit test logs https://builds.apache.org/job/PreCommit-HADOOP-Build/9086/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_77.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9086/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9086/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 7m 22s trunk passed
        +1 compile 8m 36s trunk passed with JDK v1.8.0_77
        +1 compile 7m 36s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 20s trunk passed
        +1 mvnsite 1m 5s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 41s trunk passed
        +1 javadoc 1m 4s trunk passed with JDK v1.8.0_77
        +1 javadoc 1m 8s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 47s the patch passed
        +1 compile 8m 26s the patch passed with JDK v1.8.0_77
        +1 javac 8m 26s the patch passed
        +1 compile 7m 37s the patch passed with JDK v1.7.0_95
        +1 javac 7m 37s the patch passed
        +1 checkstyle 0m 19s the patch passed
        +1 mvnsite 1m 2s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 53s the patch passed
        +1 javadoc 1m 6s the patch passed with JDK v1.8.0_77
        +1 javadoc 1m 9s the patch passed with JDK v1.7.0_95
        +1 unit 14m 26s hadoop-common in the patch passed with JDK v1.8.0_77.
        +1 unit 15m 24s hadoop-common in the patch passed with JDK v1.7.0_95.
        -1 asflicense 0m 26s Patch generated 1 ASF License warnings.
        83m 21s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12798556/HADOOP-12974v1.patch
        JIRA Issue HADOOP-12974
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 22cef1e235ea 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / e0cb426
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9083/testReport/
        asflicense https://builds.apache.org/job/PreCommit-HADOOP-Build/9083/artifact/patchprocess/patch-asflicense-problems.txt
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9083/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        eclark Elliott Clark added a comment -

        Patch that creates a CachingGetSpaceUsed implementation that uses DF rather than DU to get the used space. I still need to get some more documentation and a test on this.

        eclark Elliott Clark added a comment -

        This patch is based upon the patch in HADOOP-12973


          People

          • Assignee:
            eclark Elliott Clark
            Reporter:
            eclark Elliott Clark
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development