Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12647

Add /usr/lib default for ISAL library and fix missing .c file in CMakeLists

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      It was found the building will fail when use -Drequire.isal only (without -Disal.prefix and -Disal.lib options) to build ISA-L in order to use the default library installation. The cause is the mvn executor doesn't know where to find the dynamic so file.

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8997 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8997/)
        HADOOP-12647. Add /usr/lib default for ISAL library and fix missing .c (cmccabe: rev f349d0a76c8fa9c19a9f697c23a3c9337309c383)

        • hadoop-common-project/hadoop-common/src/CMakeLists.txt
        • hadoop-common-project/hadoop-common/pom.xml
        • hadoop-common-project/hadoop-common/CHANGES.txt
        cmccabe Colin P. McCabe added a comment -

        +1. Thanks, Kai.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 mvninstall 8m 33s trunk passed
        +1 compile 9m 13s trunk passed with JDK v1.8.0_66
        +1 compile 9m 30s trunk passed with JDK v1.7.0_91
        +1 mvnsite 1m 7s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 javadoc 0m 58s trunk passed with JDK v1.8.0_66
        +1 javadoc 1m 6s trunk passed with JDK v1.7.0_91
        +1 mvninstall 1m 43s the patch passed
        +1 compile 8m 42s the patch passed with JDK v1.8.0_66
        +1 cc 8m 42s the patch passed
        +1 javac 8m 42s the patch passed
        +1 compile 9m 20s the patch passed with JDK v1.7.0_91
        +1 cc 9m 20s the patch passed
        +1 javac 9m 20s the patch passed
        +1 mvnsite 1m 5s the patch passed
        +1 mvneclipse 0m 15s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 xml 0m 0s The patch has no ill-formed XML file.
        +1 javadoc 0m 58s the patch passed with JDK v1.8.0_66
        +1 javadoc 1m 5s the patch passed with JDK v1.7.0_91
        +1 unit 8m 28s hadoop-common in the patch passed with JDK v1.8.0_66.
        -1 unit 17m 18s hadoop-common in the patch failed with JDK v1.7.0_91.
        +1 asflicense 0m 24s Patch does not generate ASF License warnings.
        80m 51s



        Reason Tests
        JDK v1.7.0_91 Failed junit tests hadoop.metrics2.impl.TestGangliaMetrics
        JDK v1.7.0_91 Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12777952/HADOOP-12647-v1.patch
        JIRA Issue HADOOP-12647
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml cc
        uname Linux 64969a002c56 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / bfadf11
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8274/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.7.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-HADOOP-Build/8274/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.7.0_91.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8274/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Max memory used 76MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8274/console

        This message was automatically generated.

        drankye Kai Zheng added a comment -

        Tested the changes as follows:

        • Case 1. Build with default ISA-L installation
          • Installing ISA-L to /usr/lib the default folder the library uses
          • mvn build hadoop using -Drequire.isal option only, run mvn -Pnative package -Drequire.isal -DskipTests -Pdist passed
        • Case 2. Build with customized ISA-L installation
          • Installing ISA-L to a custom folder like /tmp/isal
          • mvn build hadoop using the installation, run mvn -Pnative package -Drequire.isal -Disal.prefix=/tmp/isal -DskipTests -Pdist passed
        • Case 3. Build tar dist package with customized ISA-L installaton
          • Installing ISA-L to a custom folder like /tmp/isal
          • mvn build hadoop using the installation, run mvn -Pnative package -Drequire.isal -Disal.lib=/tmp/isal -Dbundle.isal -DskipTests -Pdist -Dtar passed
          • Checked the result tar package is valid and contains ISA-L library files
            In all cases, run hadoop checknative passed.
            Also tested negative cases.
        drankye Kai Zheng added a comment -

        Uploaded a patch:

        • Fixed the building issue when only -Drequire.isal option is specified;
        • Also fixed the root cause for the issue HADOOP-12638.

        Colin P. McCabe, could you give this a review? I'm sorry for missing a place in HADOOP-11887 when working on later versions.


          People

          • Assignee:
            drankye Kai Zheng
            Reporter:
            drankye Kai Zheng
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development