Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12636

Prevent ServiceLoader failure init for unused FileSystems

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.2
    • Fix Version/s: 2.8.0, 2.7.3, 3.0.0-alpha1
    • Component/s: fs
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      loadFileSystems() loads all the Filesystems in the path. However, some Filesystems cannot be initialized. There is no point on failing the startup because a Filesystem that won't be used.

      1. HADOOP-12636-1.patch
        2 kB
        Inigo Goiri
      2. HADOOP-12636-2.patch
        3 kB
        Inigo Goiri

        Issue Links

          Activity

          elgoiri Inigo Goiri added a comment -

          One example is when S3AFileSystem is in the path and we don't have the AWS SDK in the path. Even when we are trying to load HDFS, we get this fatal error:

          java.util.ServiceConfigurationError: org.apache.hadoop.fs.FileSystem: Provider org.apache.hadoop.fs.s3a.S3AFileSystem could not be instantiated
          at java.util.ServiceLoader.fail(ServiceLoader.java:224)
          at java.util.ServiceLoader.access$100(ServiceLoader.java:181)
          at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:377)
          at java.util.ServiceLoader$1.next(ServiceLoader.java:445)
          at org.apache.hadoop.fs.FileSystem.loadFileSystems(FileSystem.java:2617)
          at org.apache.hadoop.fs.FileSystem.getFileSystemClass(FileSystem.java:2633)
          at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2650)
          at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:92)
          at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2689)
          at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2671)
          at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:371)
          at org.apache.hadoop.fs.FileSystem.getLocal(FileSystem.java:342)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.makeInstance(DataNode.java:2284)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:2182)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:2229)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:2409)
          at org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:2433)
          Caused by: java.lang.NoClassDefFoundError: com/amazonaws/auth/AWSCredentialsProvider
          at java.lang.Class.getDeclaredConstructors0(Native Method)
          at java.lang.Class.privateGetDeclaredConstructors(Class.java:2532)
          at java.lang.Class.getConstructor0(Class.java:2842)
          at java.lang.Class.newInstance(Class.java:345)
          at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:373)
          ... 14 more
          Caused by: java.lang.ClassNotFoundException: com.amazonaws.auth.AWSCredentialsProvider
          at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
          at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
          at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
          ... 19 more

          I propose to capture these exception in loadFilesystems and when the user actually tries to use the failed Filesystem will get the proper error.

          elgoiri Inigo Goiri added a comment -

          Capture exceptions in loadFilesystems.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 7m 59s trunk passed
          +1 compile 9m 7s trunk passed with JDK v1.8.0_66
          +1 compile 9m 23s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 17s trunk passed
          +1 mvnsite 1m 7s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 1m 56s trunk passed
          +1 javadoc 1m 2s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 12s trunk passed with JDK v1.7.0_91
          -1 mvninstall 0m 25s hadoop-common in the patch failed.
          -1 compile 0m 37s root in the patch failed with JDK v1.8.0_66.
          -1 javac 0m 37s root in the patch failed with JDK v1.8.0_66.
          -1 compile 0m 41s root in the patch failed with JDK v1.7.0_91.
          -1 javac 0m 41s root in the patch failed with JDK v1.7.0_91.
          -1 checkstyle 0m 18s Patch generated 1 new checkstyle issues in hadoop-common-project/hadoop-common (total was 140, now 140).
          -1 mvnsite 0m 27s hadoop-common in the patch failed.
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          -1 findbugs 0m 24s hadoop-common in the patch failed.
          +1 javadoc 1m 2s the patch passed with JDK v1.8.0_66
          +1 javadoc 1m 11s the patch passed with JDK v1.7.0_91
          -1 unit 0m 29s hadoop-common in the patch failed with JDK v1.8.0_66.
          -1 unit 0m 27s hadoop-common in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 24s Patch does not generate ASF License warnings.
          39m 59s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12777377/HADOOP-12636-1.patch
          JIRA Issue HADOOP-12636
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux d2666ad88b5c 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / de522d2
          findbugs v3.0.0
          mvninstall https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-mvninstall-hadoop-common-project_hadoop-common.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-compile-root-jdk1.8.0_66.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-compile-root-jdk1.8.0_66.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/diff-checkstyle-hadoop-common-project_hadoop-common.txt
          mvnsite https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-mvnsite-hadoop-common-project_hadoop-common.txt
          findbugs https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-findbugs-hadoop-common-project_hadoop-common.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/testReport/
          modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
          Max memory used 75MB
          Powered by Apache Yetus 0.1.0 http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8234/console

          This message was automatically generated.

          elgoiri Inigo Goiri added a comment -

          Added unit test.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 7m 43s trunk passed
          +1 compile 7m 49s trunk passed with JDK v1.8.0_66
          +1 compile 8m 37s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 16s trunk passed
          +1 mvnsite 1m 2s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 1m 47s trunk passed
          +1 javadoc 0m 52s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 3s trunk passed with JDK v1.7.0_91
          +1 mvninstall 1m 47s the patch passed
          +1 compile 7m 44s the patch passed with JDK v1.8.0_66
          -1 javac 13m 14s root-jdk1.8.0_66 with JDK v1.8.0_66 generated 1 new issues (was 730, now 730).
          +1 javac 7m 44s the patch passed
          +1 compile 8m 38s the patch passed with JDK v1.7.0_91
          +1 javac 8m 38s the patch passed
          -1 checkstyle 0m 15s Patch generated 1 new checkstyle issues in hadoop-common-project/hadoop-common (total was 140, now 140).
          +1 mvnsite 0m 59s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 55s the patch passed
          +1 javadoc 0m 51s the patch passed with JDK v1.8.0_66
          +1 javadoc 1m 0s the patch passed with JDK v1.7.0_91
          -1 unit 6m 34s hadoop-common in the patch failed with JDK v1.8.0_66.
          -1 unit 7m 6s hadoop-common in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 23s Patch does not generate ASF License warnings.
          67m 57s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.fs.shell.TestCopyPreserveFlag
            hadoop.ipc.TestIPC
          JDK v1.7.0_91 Failed junit tests hadoop.net.TestClusterTopology



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12777626/HADOOP-12636-2.patch
          JIRA Issue HADOOP-12636
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 54f06b4dee2f 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / d8a4542
          findbugs v3.0.0
          javac root-jdk1.8.0_66: https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/diff-compile-javac-root-jdk1.8.0_66.txt
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/diff-checkstyle-hadoop-common-project_hadoop-common.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/testReport/
          modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
          Max memory used 75MB
          Powered by Apache Yetus 0.1.0 http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8237/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Removed fix version. Please don't set fix version before the patch is not committed. The fix version is set by the committer who commit the patch.

          elgoiri Inigo Goiri added a comment -

          My bad... the patch available transition was asking for versions and I started setting them like crazy.

          chris.douglas Chris Douglas added a comment -

          Of the results for test-patch: TestClusterTopology failures are unrelated, the checkstyle error for FileSystem length is not relevant, and the unchecked cast was not introduced by the patch.

          I committed this. Thanks, Inigo

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9003 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9003/)
          HADOOP-12636. Prevent ServiceLoader failure init for unused FileSystems. (cdouglas: rev 8652cce5b21825f6f835e4ea31de82eb59fb06c1)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestFileSystemInitialization.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileSystem.java
          elgoiri Inigo Goiri added a comment -

          Thanks Chris Douglas!

          stevel@apache.org Steve Loughran added a comment -

          ..I think we should backport this to 2.7.x

          ajisakaa Akira Ajisaka added a comment -

          +1 for backporting this to 2.7.x

          chris.douglas Chris Douglas added a comment -

          I think we should backport this to 2.7.x

          +1. Though logging the exception (particularly at WARN) can be annoying, I don't have a better suggestion.

          stevel@apache.org Steve Loughran added a comment -

          Cherry picked into 2.7.3

          vinodkv Vinod Kumar Vavilapalli added a comment -

          This never made it to branch-2.7.3, even though it was marked so. I just merged it in from branch-2.7.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Closing the JIRA as part of 2.7.3 release.


            People

            • Assignee:
              elgoiri Inigo Goiri
              Reporter:
              elgoiri Inigo Goiri
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development