Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12553

[JDK8] Fix javadoc error caused by illegal tag

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: build, documentation
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      After HADOOP-11684, mvn package -Pdist -DskipTests fails on JDK8.

      [ERROR] Exit code: 1 - /testptch/hadoop/hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java:50: error: invalid uri: "https://github
      [ERROR] * This is inspired by <a href = "https://github
      [ERROR] ^
      [ERROR] .com/apache/incubator-s4/blob/master/subprojects
      [ERROR] /s4-comm/src/main/java/org/apache/s4/comm/staging
      [ERROR] /BlockingThreadPoolExecutorService.java"
      

        Issue Links

          Activity

          ajisakaa Akira Ajisaka added a comment -

          Attached a patch to fix the error.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 11s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 3m 31s trunk passed
          +1 compile 0m 16s trunk passed with JDK v1.8.0_60
          +1 compile 0m 15s trunk passed with JDK v1.7.0_79
          +1 checkstyle 0m 10s trunk passed
          +1 mvneclipse 0m 15s trunk passed
          +1 findbugs 0m 37s trunk passed
          -1 javadoc 0m 18s hadoop-aws in trunk failed with JDK v1.8.0_60.
          +1 javadoc 0m 17s trunk passed with JDK v1.7.0_79
          +1 mvninstall 0m 17s the patch passed
          +1 compile 0m 16s the patch passed with JDK v1.8.0_60
          +1 javac 0m 16s the patch passed
          +1 compile 0m 15s the patch passed with JDK v1.7.0_79
          +1 javac 0m 15s the patch passed
          -1 checkstyle 0m 9s Patch generated 1 new checkstyle issues in hadoop-tools/hadoop-aws (total was 5, now 6).
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 46s the patch passed
          +1 javadoc 0m 18s the patch passed with JDK v1.8.0_60
          +1 javadoc 0m 16s the patch passed with JDK v1.7.0_79
          +1 unit 0m 16s hadoop-aws in the patch passed with JDK v1.8.0_60.
          +1 unit 0m 15s hadoop-aws in the patch passed with JDK v1.7.0_79.
          +1 asflicense 0m 28s Patch does not generate ASF License warnings.
          10m 31s



          Subsystem Report/Notes
          Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-06
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770985/HADOOP-12553.00.patch
          JIRA Issue HADOOP-12553
          Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
          uname Linux e67fd64ed5cc 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HADOOP-Build/patchprocess/apache-yetus-ee5baeb/precommit/personality/hadoop.sh
          git revision trunk / 66c0967
          Default Java 1.7.0_79
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
          findbugs v3.0.0
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/8041/artifact/patchprocess/branch-javadoc-hadoop-tools_hadoop-aws-jdk1.8.0_60.txt
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/8041/artifact/patchprocess/diff-checkstyle-hadoop-tools_hadoop-aws.txt
          JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8041/testReport/
          modules C: hadoop-tools/hadoop-aws U: hadoop-tools/hadoop-aws
          Max memory used 226MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8041/console

          This message was automatically generated.

          aw Allen Wittenauer added a comment -

          +1

          fabbri Aaron Fabbri added a comment -

          +1 Thanks for fixing this.

          eddyxu Lei (Eddy) Xu added a comment -

          +1 Thanks a lot for fixing it, Akira Ajisaka.

          brahmareddy Brahma Reddy Battula added a comment -

          Thanks Akira Ajisaka for quick patch..but still jenkins shows following..

          -1 javadoc 0m 18s hadoop-aws in trunk failed with JDK v1.8.0_60.

          and please fix the check-style issue also..

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8774 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8774/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk. Thanks Allen, Aaron, Eddy, and Brahma for reviewing the patch.

          still jenkins shows following..

          I don't know why jenkins build is still failing. I tested my patch and it worked well.

          please fix the check-style issue

          The warning "the line is longer than 80 chars" is unavoidable. If we are to render the line, we need to break the tag.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #642 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/642/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2582 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2582/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #652 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/652/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1376 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1376/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #583 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/583/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2522 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2522/)
          HADOOP-12553. [JDK8] Fix javadoc error caused by illegal tag. (aajisaka) (aajisaka: rev 3ae82863f045d27b3e29cea2f622e229e7f00690)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/BlockingThreadPoolExecutorService.java

            People

            • Assignee:
              ajisakaa Akira Ajisaka
              Reporter:
              ajisakaa Akira Ajisaka
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development