Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12533

Introduce FileNotFoundException in WASB for read and seek API

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: tools
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Currently WASB throws a IOException in read and seek API for both Block and Page blobs for scenarios where the backing blobs do not exists. This creates problems for applications like HBase which expect a FileNotFoundException in these scenarios.

      The fix for the problem is to check if the exceptions from Azure storage is because for Blob not found and throw FileNotFound exception if that is the case.

      1. HADOOP-12533.001.patch
        17 kB
        Dushyanth
      2. HADOOP-12533.002.patch
        18 kB
        Dushyanth
      3. HADOOP-12533.003.patch
        18 kB
        Dushyanth
      4. HADOOP-12533.004.patch
        19 kB
        Dushyanth
      5. HADOOP-12533.005.patch
        19 kB
        Dushyanth

        Activity

        dchickabasapa Dushyanth added a comment -

        Added first iteration for the fix.

        stevel@apache.org Steve Loughran added a comment -
        1. nice to see a concurrency test in there
        2. I don't see any test cleanup though....shouldn't those input streams be closed?

        If you're finding and fixing bits where azure storage client behaves differently from HDFS, I'd recommend you consider implementing the AbstractFSContract suite of tests for WASB, as I don't see it there right now. It does do seek testing, including the various corner cases ... and could have found this mismatch. (actually, I'm not sure what the other filesystems do if you rename a file that's being read, usually that's a "things may fail, failure modes undefined).

        dchickabasapa Dushyanth added a comment -

        Steve Loughran Thanks steve.

        For 2. Since the files are deleted and the correctness of the test depends on getting the exception, I didn't close the streams.

        Thanks for the suggestion. I think adding the AbstractFSContract suite of tests can be done as improvement. I would let Chris comment on this.

        cnauroth Chris Nauroth added a comment - - edited

        Dushyanth, thank you for the patch.

          public static final String AZURE_STORAGE_BLOBNOTFOUND_ERRORCODE = "BlobNotFound";
          public static final String AZURE_STORAGE_RESOURCENOTFOUND_ERRORCODE = "RESOURCE_NOT_FOUND";
        

        Instead of repeating these constants within hadoop-azure, do you want to use com.microsoft.azure.storage#BLOB_NOT_FOUND and #RESOURCE_NOT_FOUND? (BTW, is the second one really meant to have a value of "ResourceNotFound"? That's how it's defined in the SDK.

                    throw new FileNotFoundException();
        

        Please pass a descriptive string to help with troubleshooting any time you call an exception constructor. For a FileNotFoundException, including the file path is very helpful.

        The exception unwinding logic is repeated multiple times. Can that be refactored into a shared helper method?

        Since the files are deleted and the correctness of the test depends on getting the exception, I didn't close the streams.

        Please ensure all streams get closed anyway at the end of the test. If you need the stream to be left open while doing some other logic and running assertions, then that's fine, but proper cleanup at the end of a test run is still good practice.

        I think adding the AbstractFSContract suite of tests can be done as improvement.

        This has come up as feedback on multiple code reviews. The contract tests are a great way to catch early if a FileSystem implementation is not satisfying the semantics that Hadoop expects. I appreciate controlling the scope of this patch, but I also see this as a deferred maintenance problem, ultimately causing more churn as patches come in piecemeal.

        I've filed HADOOP-12535 to track work on the contract tests. Dushyanth, I tentatively assigned this to you. If this is not something that you're going to work on, please unassign it, so that someone else interested in the community can pick it up.

        cnauroth Chris Nauroth added a comment -

        Duo Xu, sorry for the confusion if you received an email on the earlier comment. I meant it for Dushyanth.

        dchickabasapa Dushyanth added a comment -

        Thanks Chris Nauroth for the quick CR.

        1) I have made the change to use error codes from the Azure Storage SDK classes. However the Java Azure storage SDK, does not handle error codes consistently. In some places the error code returned back from the SDK is from [~StorageErrorCode] enum class (https://github.com/Azure/azure-storage-java/blob/9248873511c14f112fcae5f6402447a7fab76162/microsoft-azure-storage/src/com/microsoft/azure/storage/StorageErrorCode.java) as its the case here in [~StorageException.java] (https://github.com/Azure/azure-storage-java/blob/9248873511c14f112fcae5f6402447a7fab76162/microsoft-azure-storage/src/com/microsoft/azure/storage/StorageException.java#L128) and in some cases it is from the StorageErrorCodeStrings class. So I have refactored the code to handle both possible cases.

        2) I have added exception message for FileNotFoundException.

        3) I have added teardown method to close the inputstream after each test.

        4) I will check with my manager to see if I need to pick up the adding of AbstractFSContract suite to WASB.

        stevel@apache.org Steve Loughran added a comment -

        seek()

        1. I'd go from e.getMessage() in the log statement to just e; some exceptions don't have a message, but they do have a toString() value. I don't think it's the case here, but it's still a practise we shouldn't have in the codebase.
        2. in that try/catch statement, I'd add a check for in being non-null before closing it. Use {{ IOUtils.closeStream(in)}} for this

        Looking at the whole input stream code, I can see that the close operation always assumes in is valid too, it sets closed=true after closing the stream in an unsynced method, and checks for that closed==true flag are patchy. Best to review that code and consistently reject operations like seek on a closed stream., maybe in close() catch exceptions in in.close() and always set it to null afterwards.

        public synchronized void close() throws IOException {
          if (!closed) {
            closed = true;
            IOUtils.closeStream(in)
            in = null;
          }
        }
        

        Not sure if this patch is the right place for that (it'll show up in the FS contract tests), but at the very least seek() should refuse to seek if closed==true and use IOUtils for that close.

        cnauroth Chris Nauroth added a comment -

        Dushyanth, thank you for posting a new patch. I'm clicking the Submit Patch button to trigger a Jenkins pre-commit test run. Please do respond to Steve's feedback too. Thanks!

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 6s docker + precommit patch detected.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        +1 mvninstall 3m 22s trunk passed
        +1 compile 0m 12s trunk passed with JDK v1.8.0_60
        +1 compile 0m 14s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 7s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 0m 31s trunk passed
        +1 javadoc 0m 12s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 14s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 16s the patch passed
        +1 compile 0m 11s the patch passed with JDK v1.8.0_60
        +1 javac 0m 11s the patch passed
        +1 compile 0m 14s the patch passed with JDK v1.7.0_79
        +1 javac 0m 14s the patch passed
        -1 checkstyle 0m 7s Patch generated 5 new checkstyle issues in hadoop-tools/hadoop-azure (total was 26, now 30).
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 36s the patch passed
        +1 javadoc 0m 11s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 14s the patch passed with JDK v1.7.0_79
        +1 unit 1m 1s hadoop-azure in the patch passed with JDK v1.8.0_60.
        +1 unit 1m 15s hadoop-azure in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 24s Patch does not generate ASF License warnings.
        10m 53s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-10-31
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12769916/HADOOP-12533.002.patch
        JIRA Issue HADOOP-12533
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux 8ab504c74d4a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HADOOP-Build/patchprocess/apache-yetus-e77b1ce/precommit/personality/hadoop.sh
        git revision trunk / 7fd6416
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/7988/artifact/patchprocess/diff-checkstyle-hadoop-tools_hadoop-azure.txt
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7988/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Max memory used 224MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7988/console

        This message was automatically generated.

        cnauroth Chris Nauroth added a comment -

        Dushyanth, in addition to Steve's feedback, please also address the Checkstyle warning from the Jenkins run. Thank you.

        dchickabasapa Dushyanth added a comment -

        Steve Loughran Chris Nauroth Thanks a lot for the CR.

        Steve I addressed both comments on the previous iteration.

        Chris I fixed the style check warnings.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 5s docker + precommit patch detected.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        +1 mvninstall 3m 2s trunk passed
        +1 compile 0m 12s trunk passed with JDK v1.8.0_60
        +1 compile 0m 13s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 7s trunk passed
        +1 mvneclipse 0m 11s trunk passed
        +1 findbugs 0m 29s trunk passed
        +1 javadoc 0m 11s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 13s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 15s the patch passed
        +1 compile 0m 11s the patch passed with JDK v1.8.0_60
        +1 javac 0m 11s the patch passed
        +1 compile 0m 13s the patch passed with JDK v1.7.0_79
        +1 javac 0m 13s the patch passed
        +1 checkstyle 0m 7s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 38s the patch passed
        +1 javadoc 0m 11s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 14s the patch passed with JDK v1.7.0_79
        +1 unit 1m 2s hadoop-azure in the patch passed with JDK v1.8.0_60.
        +1 unit 1m 15s hadoop-azure in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 20s Patch does not generate ASF License warnings.
        10m 20s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-10-31
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12769961/HADOOP-12533.003.patch
        JIRA Issue HADOOP-12533
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux 217cb6b7c43a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HADOOP-Build/patchprocess/apache-yetus-e77b1ce/precommit/personality/hadoop.sh
        git revision trunk / 7fd6416
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        findbugs v3.0.0
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7991/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Max memory used 226MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7991/console

        This message was automatically generated.

        stevel@apache.org Steve Loughran added a comment -

        w.r.t closing checks on seek(), I'd lift the check from S3AInputStream

        private void checkNotClosed() throws IOException {
          if (closed) {
            throw new IOException(FSExceptionMessages.STREAM_IS_CLOSED);
          }
        }
        

        call that at the start of the seek()
        Then add a check for a negative position

        public synchronized void seek(long pos) throws IOException {
          checkNoClosed()
          if (targetPos < 0) {
            throw new EOFException(FSExceptionMessages.NEGATIVE_SEEK);
          }
        
        dchickabasapa Dushyanth added a comment -

        Addressed Steve's Comments.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 8s docker + precommit patch detected.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        +1 mvninstall 3m 13s trunk passed
        +1 compile 0m 14s trunk passed with JDK v1.8.0_60
        +1 compile 0m 14s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 8s trunk passed
        +1 mvneclipse 0m 11s trunk passed
        +1 findbugs 0m 32s trunk passed
        +1 javadoc 0m 13s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 14s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 15s the patch passed
        +1 compile 0m 12s the patch passed with JDK v1.8.0_60
        +1 javac 0m 12s the patch passed
        +1 compile 0m 14s the patch passed with JDK v1.7.0_79
        +1 javac 0m 14s the patch passed
        +1 checkstyle 0m 7s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 38s the patch passed
        +1 javadoc 0m 12s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 13s the patch passed with JDK v1.7.0_79
        +1 unit 1m 2s hadoop-azure in the patch passed with JDK v1.8.0_60.
        +1 unit 1m 17s hadoop-azure in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 23s Patch does not generate ASF License warnings.
        10m 51s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-01
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770000/HADOOP-12533.004.patch
        JIRA Issue HADOOP-12533
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux f5b19cdd3f03 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HADOOP-Build/patchprocess/apache-yetus-e77b1ce/precommit/personality/hadoop.sh
        git revision trunk / 7fd6416
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        findbugs v3.0.0
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7994/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Max memory used 226MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7994/console

        This message was automatically generated.

        cnauroth Chris Nauroth added a comment -

        Dushyanth, the close logic is only correct if the method is marked synchronized. Otherwise, 2 threads could enter the close method, both get past the check on the closed flag and then double-close the underlying stream. There could also be a problem with a concurrent seek} getting past the checkNotClosed check, but then finding that another thread ran close before it could complete the method.

        There is a strong encouragement that implementations of the JDK stream classes should provide an idempotent close operation. Marking it synchronized would help achieve that goal.

        After close is marked synchronized and we get a fresh Jenkins pre-commit run, I think the patch will be ready to commit. I'll wait a bit before committing in case Steve has additional feedback.

        dchickabasapa Dushyanth added a comment -

        Addressed Chris Nauroth comments.

        Steve Loughran can you please take a look.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 8s docker + precommit patch detected.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        -1 mvninstall 1m 42s root in trunk failed.
        +1 compile 0m 18s trunk passed with JDK v1.8.0_60
        +1 compile 0m 13s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 10s trunk passed
        +1 mvneclipse 0m 36s trunk passed
        +1 findbugs 0m 34s trunk passed
        +1 javadoc 0m 13s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 13s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 14s the patch passed
        +1 compile 0m 12s the patch passed with JDK v1.8.0_60
        +1 javac 0m 12s the patch passed
        +1 compile 0m 12s the patch passed with JDK v1.7.0_79
        +1 javac 0m 12s the patch passed
        +1 checkstyle 0m 9s the patch passed
        +1 mvneclipse 0m 10s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 41s the patch passed
        +1 javadoc 0m 12s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 13s the patch passed with JDK v1.7.0_79
        +1 unit 1m 14s hadoop-azure in the patch passed with JDK v1.8.0_60.
        +1 unit 1m 24s hadoop-azure in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 28s Patch does not generate ASF License warnings.
        10m 13s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-02
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770019/HADOOP-12533.005.patch
        JIRA Issue HADOOP-12533
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux 9f9cb19eab09 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HADOOP-Build/patchprocess/apache-yetus-e77b1ce/precommit/personality/hadoop.sh
        git revision trunk / 6e4f8a4
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        mvninstall https://builds.apache.org/job/PreCommit-HADOOP-Build/7995/artifact/patchprocess/branch-mvninstall-root.txt
        findbugs v3.0.0
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7995/testReport/
        modules C: hadoop-tools/hadoop-azure U: hadoop-tools/hadoop-azure
        Max memory used 65MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7995/console

        This message was automatically generated.

        dchickabasapa Dushyanth added a comment -

        Chris Nauroth I see that Hadoop QA run failed in mvninstall subsystem. The failure seems to be in hadoop-common. The only change between the previous patch and this one was making close() synchronized. Which I doubt would have any effect on mvninstall. Is this a legitimate issue or a transient failure?

        [~Steve Loughran] This is hitting a bit of deadline for a release, so it would be great if we can get a review from you. Sorry for the inconvenience.

        cnauroth Chris Nauroth added a comment -

        This is hitting a bit of deadline for a release...

        This patch currently is targeted to Apache Hadoop 2.8.0, which does not yet have any proposed release timeline. That said, I do expect we can finish this out today and commit.

        cnauroth Chris Nauroth added a comment -

        +1 for patch v005. I have committed this to trunk and branch-2. Dushyanth, thank you for contributing the patch. Steve Loughran, thank you for helping with the code review.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8743 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8743/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #617 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/617/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #628 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/628/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2558 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2558/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #1351 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1351/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #564 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/564/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2501 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2501/)
        HADOOP-12533. Introduce FileNotFoundException in WASB for read and seek (cnauroth: rev 3ce0a6502e78240f551c29bb27a2324ce359cd70)

        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationsExceptionHandlingMultiThreaded.java
        • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
        • hadoop-tools/hadoop-azure/src/test/java/org/apache/hadoop/fs/azure/TestFileSystemOperationExceptionHandling.java
        • hadoop-common-project/hadoop-common/CHANGES.txt

          People

          • Assignee:
            dchickabasapa Dushyanth
            Reporter:
            dchickabasapa Dushyanth
          • Votes:
            0 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development