Hadoop Common
  1. Hadoop Common
  2. HADOOP-1249

Unit test for detecting corruption of replicas in DFS

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      DFS has this important feature that the DFSClient detects corrupted replicas of a block. We need a unit test that ensures that DFSClient is directed to access a good copy of a block and ignores corrupted replicas. The existing unit test named TestFileCorruption does not test this feature.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          84d 18h 44m 1 dhruba borthakur 05/Jul/07 17:57
          Resolved Resolved Closed Closed
          12d 3h 25m 1 Doug Cutting 17/Jul/07 21:22
          Owen O'Malley made changes -
          Component/s dfs [ 12310710 ]
          Doug Cutting made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          dhruba borthakur made changes -
          Link This issue is duplicated by HADOOP-1564 [ HADOOP-1564 ]
          dhruba borthakur made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          dhruba borthakur added a comment -

          Duplicate of HADOOP-1564

          dhruba borthakur created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              dhruba borthakur
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development