Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: io
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Commented by Tsz-wo Sze in HADOOP-12029:

      We should also change "k" and "m" in the following to something like "numDataUnits" and "numParityUnits".

         public static final String NUM_DATA_UNITS_KEY = "k";
         public static final String NUM_PARITY_UNITS_KEY = "m";
      

      This sounds good to me, as in fact in many erasure coding related papers, discussions, and implementations, though k and m are broadly used, the meanings are not consistent. For example, m can also mean numDataUnits + numParityUnits, all the rows in the coding matrix. The suggested names are more clear and explicit.

        Attachments

          Activity

            People

            • Assignee:
              drankye Kai Zheng
              Reporter:
              drankye Kai Zheng
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: