Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-11296

hadoop-daemons.sh throws 'host1: bash: host3: command not found...'

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: scripts
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      hadoop-daemons.sh throws command not found.

      [vinay@host2 install]$ /home/vinay/install/hadoop/sbin/hadoop-[vinay@host2 install]$ /home/vinay/install/hadoop/sbin/hadoop-daemons.sh --config /home/vinay/install/conf --hostnames 'host1 host2' start namenode
      host1: bash: host2: command not found...
      

      hadoop-daemons.sh is mainly used to start the cluster, for ex: start-dfs.sh

      Without this cluster will not be able to start.

      1. HADOOP-11296-001.patch
        0.9 kB
        Vinayakumar B
      2. HADOOP-11296-002.patch
        1 kB
        Vinayakumar B

        Activity

        vinayrpet Vinayakumar B added a comment -

        Issue was 'xargs' will consider full line of input as one argument when it reads from stdin/pipe.
        in hadoop-functions.sh#hadoop_connect_to_hosts SLAVE_NAMES was space separated hostnames in one line. So it was considering whole list as one host.
        Here is the code snippet.

            echo "${SLAVE_NAMES}" | \
            xargs -n 1 -P"${HADOOP_SSH_PARALLEL}" \
            -I {} bash -c --  "hadoop_actual_ssh {} ${params}"
        vinayrpet Vinayakumar B added a comment -

        Hi Allen Wittenauer, can you take a look at the patch? thanks

        vinayrpet Vinayakumar B added a comment -

        Lowering the Priority to major as this is only in trunk.

        iwasakims Masatake Iwasaki added a comment -

        Vinayakumar B Which version of hadoop are you using? You set the "Affects Version/s" to 2.5.1 but your comment and patch looks referring to trunk.

        vinayrpet Vinayakumar B added a comment -

        Updated affects version also

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12680777/HADOOP-11296-001.patch
        against trunk revision 58e9bf4.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common:

        org.apache.hadoop.ha.TestZKFailoverControllerStress

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5063//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5063//console

        This message is automatically generated.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #740 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/740/)
        HADOOP-11296. Nfs3FileAttributes should not change the values of rdev, nlink and size in the constructor. Contributed by Brandon Li. (wheat9: rev 2cc868dede3187ef3e122e878b8ee0882c82dc81)

        • hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/Nfs3Utils.java
        • hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3FileAttributes.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        iwasakims Masatake Iwasaki added a comment -

        Haohui Mai issue id in the commit message seems to be wrong.

        iwasakims Masatake Iwasaki added a comment -

        -n 1 in xargs options means taking at most 1 argument at a time as

        $ echo 'foo bar' | xargs -n 1 echo
        foo
        bar
        

        How can I reproduce the problem?

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Hdfs-trunk #1930 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1930/)
        HADOOP-11296. Nfs3FileAttributes should not change the values of rdev, nlink and size in the constructor. Contributed by Brandon Li. (wheat9: rev 2cc868dede3187ef3e122e878b8ee0882c82dc81)

        • hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/Nfs3Utils.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3FileAttributes.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1954 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1954/)
        HADOOP-11296. Nfs3FileAttributes should not change the values of rdev, nlink and size in the constructor. Contributed by Brandon Li. (wheat9: rev 2cc868dede3187ef3e122e878b8ee0882c82dc81)

        • hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/Nfs3Utils.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3FileAttributes.java
        vinayrpet Vinayakumar B added a comment -

        Masatake Iwasaki,

        You can verify using following test code

        #!/bin/bash
        
        function printValue(){
          echo "Printing args : $@"
        }
        
        export -f printValue
        
        echo "arg1 arg2" | 
         xargs -n 1 -P 10 -I {} bash -c -- 'printValue {} remaining args'

        output will be :

        arg1 arg2 remaining args

        But expected is

        arg1 remaining args
        arg2 remaining args

        in the above test try replacing

         echo "arg1 arg2" | 

        with

        echo "arg1
        arg2" | 
        wheat9 Haohui Mai added a comment -

        Masatake Iwasaki, thanks for the heads up. It looks like it is difficult to fix, so I probably just leave it as is.

        iwasakims Masatake Iwasaki added a comment -

        Thank for the test code, Vinayakumar B. I understand that xargs changes the behaviour by -I option. Adding comment about -I would be help.

        vinayrpet Vinayakumar B added a comment -

        added comments regarding the xargs

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12681045/HADOOP-11296-002.patch
        against trunk revision 53f64ee.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-common.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5068//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5068//console

        This message is automatically generated.

        aw Allen Wittenauer added a comment -

        It looks like this is dependent upon either the version of bash or the version of xargs, as I'm having trouble reproducing this on OS X. Even the test code gives me the expected output. What version is showing the problem?

        aw Allen Wittenauer added a comment -

        OK, it looks like OS X is the outlier. I've been able to reproduce this on both Linux and Illumos. As part of that, it looks like Illumos xargs doesn't support -P parameter (SVID issue? non-POSIX extension?). At first glance, the patch seems reasonable, but I want to test a few things out.

        vinayrpet Vinayakumar B added a comment -

        Any update on this Allen Wittenauer ? thanks

        aw Allen Wittenauer added a comment -

        +1 passed all of my tests. Thanks!

        vinayrpet Vinayakumar B added a comment -

        Thanks Allen Wittenauer. Committed to trunk

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #6637 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6637/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #763 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/763/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #24 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/24/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1955 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1955/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #24 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/24/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1978 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1978/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #24 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/24/)
        HADOOP-11296. hadoop-daemons.sh throws 'host1: bash: host3: command not found...' (Contributed by Vinayakumar B) (vinayakumarb: rev 92ce6eda920a1bab74df68c0badb4f06728fc177)

        • hadoop-common-project/hadoop-common/src/main/bin/hadoop-functions.sh
        • hadoop-common-project/hadoop-common/CHANGES.txt

          People

          • Assignee:
            vinayrpet Vinayakumar B
            Reporter:
            vinayrpet Vinayakumar B
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development