Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-11062

CryptoCodec testcases requiring OpenSSL should be run only if -Pnative is used

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0
    • Fix Version/s: 2.6.0
    • Component/s: security, test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      there are a few testcases, cryptocodec related that require Hadoop native code and OpenSSL.

      These tests should be skipped if -Pnative is not used when running the tests.

        Attachments

        1. HADOOP-11062.1.patch
          3 kB
          Arun Suresh
        2. HADOOP-11062.1.patch
          3 kB
          Arun Suresh
        3. HADOOP-11062.2.patch
          4 kB
          Arun Suresh
        4. HADOOP-11062.3.patch
          4 kB
          Arun Suresh
        5. HADOOP-11062.4.patch
          4 kB
          Arun Suresh
        6. HADOOP-11062.5.patch
          4 kB
          Arun Suresh
        7. HADOOP-11062.6.patch
          4 kB
          Arun Suresh

          Issue Links

            Activity

              People

              • Assignee:
                asuresh Arun Suresh
                Reporter:
                tucu00 Alejandro Abdelnur
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: