Description
Currently hadoop.record.RecordReader and RecordWriter act as factories for various InputArchive and OutputArchive recently. In the original design, this was done in order to have tight control over various serialization formats. This has proven to be counterproductive. For wider usage of record I/O one should be able to use their own serialization formats. The proposed changes make it possible. They are as follows:
1. Eliminate current record.RecordReader and record.RecordWriter.
2. rename InputArchive as RecordInput, and OutputArchive as RecordOutput.
3. rename various archives accordingly. e..g. BinaryInputArchive -> BinaryRecordInput etc.