Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-10702

KerberosAuthenticationHandler does not log the principal names correctly

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.5.0
    • 2.5.0
    • security
    • None
    • Reviewed

    Description

      With HADOOP-10158, it is possible to load multiple principal names or all HTTP principals in the key tab by specifying “*”.
      Each principal name is logged when when the principal is loaded from key tab. But there is a bug due to which principal name is logged each time as either “*” or the full list of principals.

      The log snippet is as below:

      2014-06-15 00:19:13,288 INFO org.apache.hadoop.security.authentication.server.KerberosAuthenticationHandler: Login using keytab /etc/hadoop/hadoop.keytab, for principal *
      2014-06-15 00:19:13,292 INFO org.apache.hadoop.security.authentication.server.KerberosAuthenticationHandler: Login using keytab /etc/hadoop/hadoop.keytab, for principal *
      2014-06-15 00:19:13,294 INFO org.apache.hadoop.security.authentication.server.KerberosAuthenticationHandler: Login using keytab /etc/hadoop/hadoop.keytab, for principal *
      2014-06-15 00:19:13,295 INFO org.apache.hadoop.security.authentication.server.KerberosAuthenticationHandler: Login using keytab /etc/hadoop/hadoop.keytab, for principal *

      Attachments

        1. HADOOP-10702.patch
          1 kB
          Benoy Antony

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            benoyantony Benoy Antony
            benoyantony Benoy Antony
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment