Details
-
Improvement
-
Status: Closed
-
Major
-
Resolution: Fixed
-
0.12.0
-
None
-
None
Description
Having the complete class name in the counter names makes them unique, but they are ugly to present to non-developers. It would be nice to have some way to have a nicer string presented to the user. Currently, the Enum is converted to a name like:
key.getDeclaringClass().getName() + "#" + key.toString()
which gives counter names like "org.apache.hadoop.examples.RandomWriter$Counters#BYTES_WRITTEN"
which is unique, but not very user friendly. Perhaps, we should strip off the class name for presenting to the users, which would allow them to make nice names. In particular, you could define an enum type that overloaded toString to print a nice user friendly string.
Thoughts?