Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-1007

Names used for map, reduce, and shuffle metrics should be unique

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 0.12.0
    • Component/s: metrics
    • Labels:
      None

      Description

      The names used for map, reduce, and shuffle metrics currently overlap:

      Map metrics:
      input_bytes
      input_records
      output_bytes
      output_records

      Recduce metrics:
      input_records
      output_records

      Shuffle metrics:
      input_bytes

      I propose that the metric names be unique:
      map_input_bytes
      map_input_records
      map_output_bytes
      map_output_records
      shuffle_input_bytes
      reduce_input_records
      reduce_output_records

        Attachments

        1. HADOOP-1007.patch
          2 kB
          Nigel Daley

          Activity

            People

            • Assignee:
              nidaley Nigel Daley
              Reporter:
              nidaley Nigel Daley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: