Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-773

Update webapp dependencies to latest stable and compatible versions

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Trivial
    • Resolution: Done
    • None
    • 1.4.0
    • guacamole-client
    • None

    Description

      Some of the dependencies of the Guacamole web application are quite old. Assuming newer versions can be used without breaking things, these dependencies should be updated.

      This issue as originally reported noted specifically that the following JavaScript dependencies have newer releases:

      • angular-translate
      • angular-translate-interpolation-message-format
      • angular-translate-loader-static-files
      • Blob-polyfill
      • Datalist-polyfill
      • Lodash

      It's unlikely that the above have security implications, particularly in the way they are used, but checking through them and anything else within the various pom.xml would be good. Java dependencies end up bundled, as well, and are far more critical.

      Attachments

        Issue Links

          Activity

            People

              mjumper Mike Jumper
              dateno1 dateno1
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: