Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-639

Add installation of libtool-bin for Debian/Ubuntu

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 0.9.5, 0.9.14
    • Fix Version/s: 1.1.0
    • Component/s: Documentation
    • Labels:
    • Environment:
      Ubuntu 16.04.5 LTS
    • Flags:
      Important

      Description

      While reading the documentation for building Apache Guacamole from source, I saw that there is no instruction for installing libtool-bin.

       If a user follows these instructions, they may encounter this error, at the autoreconf -fi step:

      autoreconf -fi
      Can't exec "libtoolize": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 345, <GEN3> line 6.
      autoreconf: failed to run libtoolize: No such file or directory
      autoreconf: libtoolize is needed because this package uses Libtool

      I would add libtool-bin in the Required Dependencies section so users don't encounter this issue. I intend to open a PR on the documentation.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              falcon78921 James McClune
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified