Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-635

Build against and require Java 1.8

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.0.0
    • Component/s: guacamole-client
    • Labels:
      None

      Description

      As discussed on PR #319 for GUACAMOLE-220, and as discussed on the dev@ mailing list, continuing to support Java 1.6 at all levels of guacamole-client makes less and less sense:

      • Java 1.6 reached end-of-life some time ago.
      • Java 1.7 has ceased receiving further public updates.
      • Other mainstream projects which rely on Java have already moved on to 1.7+.

      Though guacamole-common should likely remain as compatible as possible, moving all other Java components forward to a 1.8 build seems best, with the upcoming major 1.0.0 release being an ideal time.

      The only non-EOL Linux distribution I've been able to find so far that lacks Java 1.8 is Ubuntu 14.04 LTS, which is reaching EOL in April 2019.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mjumper Mike Jumper
                Reporter:
                mjumper Mike Jumper
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: