Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-218

Audio stops playing on Windows Server 2016

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.13-incubating
    • Component/s: RDP
    • Labels:
      None
    • Environment:
      Windows Server 2016

      Description

      When connecting via RDP to Windows Server 2016, Guacamole handles the first audio stream correctly, but any subsequent streams fail to produce any audio. Proper streaming of audio only resumes after disconnecting and reconnecting, but fails again after the first audio stream starts and ends.

      The start of each audio stream is noted within the logs by the acceptance of a new audio format:

      guacd[4417]: Accepted format: 16-bit PCM with 2 channels at 44100 Hz
      

      The first time that message is logged, everything works correctly. The second time that message is logged (and beyond), audio fails.

        Attachments

          Activity

            People

            • Assignee:
              mjumper Mike Jumper
              Reporter:
              mjumper Mike Jumper

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment