Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-8304

Upgrade Apache Ivy from 2.4.0 to a newer version

    XMLWordPrintableJSON

    Details

    • Type: Dependency upgrade
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0-alpha-1
    • Fix Version/s: 3.0.0-rc-2
    • Component/s: None
    • Labels:
      None

      Description

      Apache Ivy is preparing a new release https://www.mail-archive.com/ivy-user@ant.apache.org/msg06244.html

      it would be nice to upgrade to the new version (or even to test it before it is released)

      there are several blocker and critical bug fixed: https://issues.apache.org/jira/projects/IVY/versions/12320744

        Attachments

        1. ivy_snapshot.patch
          0.8 kB
          Paul King
        2. test-GrapeIvyFailures-with2.4.0.zip
          1.50 MB
          Aurélien Pupier
        3. test-GrapeIvyFailures-with2.5.0-SNAPSHOT.zip
          1.62 MB
          Aurélien Pupier

          Issue Links

            Activity

              People

              • Assignee:
                daniel_sun Daniel Sun
                Reporter:
                apupier Aurélien Pupier
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: