Groovy
  1. Groovy
  2. GROOVY-5163

IncompatibleClassChangeError when running groovysh

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.4
    • Fix Version/s: 1.8.6, 2.0-beta-3
    • Component/s: Groovysh
    • Labels:
      None
    • Environment:
      Mac Java 6

      Description

      Wondering if this bug is new in Groovy 1.8.4; it seems it work better in 1.8.2.

      The problem is that groovysh is throwing IncompatibleClassChangeError in a few cases:
      import com.not.Found // import that doesn't resolve to class
      show // command doesn't run at all
      purge // command doesn't run at all

      Groovy 1.8.4 appears to be working well, otherwise.

      Please let me know if you need further info. It seems reproducible, here.

      Thanks!
      John

        Activity

          People

          • Assignee:
            Cédric Champeau
            Reporter:
            jwb
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development