Groovy
  1. Groovy
  2. GROOVY-3764

Unit tests fail on Ubuntu 9.04 x86_64 with OpenJDK

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.6.4, 1.7-beta-1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu 9.04 Jaunty Jackalope x64; OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode); Groovy HEAD 2009-09-19T11:23:0+01:00

      Description

      -testAll:
      [junit] WARNING: multiple versions of ant detected in path for junit
      [junit] jar:file:/home/users/russel/lib/Java/ant/lib/ant.jar!/org/apache/tools/ant/Project.class
      [junit] and jar:file:/tmp/russel/GroovycTagsFix/target/lib/compile/ant-1.7.1.jar!/org/apache/tools/ant/Project.class
      [junit] Running UberTestCaseBugs
      [junit] Tests run: 277, Failures: 0, Errors: 0, Time elapsed: 4.517 sec
      [junit] Running UberTestCaseGroovySourceCodehausPackages
      [junit] Tests run: 395, Failures: 0, Errors: 0, Time elapsed: 62.531 sec
      [junit] Running UberTestCaseGroovySourceRootPackage
      [junit] Tests run: 956, Failures: 0, Errors: 0, Time elapsed: 32.217 sec
      [junit] Running UberTestCaseGroovySourceSubPackages
      [junit] Tests run: 969, Failures: 0, Errors: 13, Time elapsed: 55.179 sec
      [junit] Test UberTestCaseGroovySourceSubPackages FAILED
      [junit] Running UberTestCaseGroovySourceSubPackages_VM6
      [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.169 sec
      [junit] Running UberTestCaseJavaSourceCodehausPackages
      [junit] Tests run: 599, Failures: 0, Errors: 0, Time elapsed: 30.947 sec
      [junit] Running UberTestCaseJavaSourceGroovyPackagesNonSecurity
      [junit] Tests run: 406, Failures: 0, Errors: 0, Time elapsed: 2.454 sec
      [junit] Running UberTestCaseJavaSourceGroovyPackagesSecurity
      [junit] Tests run: 16, Failures: 0, Errors: 0, Time elapsed: 9.127 sec
      [junit] Running UberTestCaseTCK
      [junit] Tests run: 202, Failures: 0, Errors: 0, Time elapsed: 4.524 sec

        Activity

        Russel Winder created issue -
        Russel Winder made changes -
        Field Original Value New Value
        Environment Ubuntu 9.04 Jaunty Jackalope; OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode); Groovy HEAD 2009-09-19T11:23:0+01:00 Ubuntu 9.04 Jaunty Jackalope x64; OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode); Groovy HEAD 2009-09-19T11:23:0+01:00
        Jochen Theodorou added a comment -

        the build works just fine for me and I use Ubuntu with a java server VM

        Jochen Theodorou made changes -
        Assignee Jochen Theodorou [ blackdrag ]
        Fix Version/s 1.6.5 [ 15539 ]
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.7-beta-2 [ 15540 ]
        Russel Winder added a comment -

        Nor can I now, so this is well closed !

        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Mark Thomas made changes -
        Workflow jira [ 12732737 ] Default workflow, editable Closed status [ 12744584 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12973652 ] Default workflow, editable Closed status [ 12980794 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        10d 3h 51m 1 Jochen Theodorou 29/Sep/09 10:17

          People

          • Assignee:
            Jochen Theodorou
            Reporter:
            Russel Winder
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development