Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 1.1-rc-3
    • Component/s: None
    • Labels:
      None

      Description

      Currently, it is possible to define closure coercion to interfaces:

      { } as Runnable

      (bad example since closures are already runnable, but still...)

      The mechanism leverages Java proxies and invocation handlers.
      The mechanism should be enhanced to allow extending classes as well.

        Activity

        Jochen Theodorou added a comment -

        duplicate of GROOVY-1724


          People

          • Assignee:
            Jochen Theodorou
            Reporter:
            Guillaume Delcroix
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development