Geronimo-Devtools
  1. Geronimo-Devtools
  2. GERONIMODEVTOOLS-338

Eclipse tooling hangs when certain errors are produced on the server side

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.2.0
    • Component/s: eclipse-plugin
    • Labels:
      None

      Description

      If you deploy a project with a class loader issue (meaning that a Class cannot be found in the runtime environment) the project publication from the tooling hangs. The only recovery option is to kill both processes (the tooling and the test environment

        Activity

        Tim McConnell created issue -
        Tim McConnell made changes -
        Field Original Value New Value
        Fix Version/s 2.1.1 [ 12313131 ]
        Fix Version/s 2.1.2 [ 12313277 ]
        Tim McConnell made changes -
        Fix Version/s 2.1.2 [ 12313277 ]
        Fix Version/s 2.1.3 [ 12312705 ]
        Ted Kirby made changes -
        Fix Version/s 2.1.3 [ 12312705 ]
        Fix Version/s 2.2.0 [ 12313331 ]
        Delos Dai added a comment -

        I tried a Dynamic Web project, with a servlet declared in web.xml. But the class file is missing(it can't be found in runtime environment). When I published it, there is a message dialog saying deployment error.

        So I think it's difficult to reproduce this JIRA, or it has been fixed in GEP 2.2. Could you give a scenario to reproduce it? If it can't be reproduced, I suggest to close it.

        Delos Dai added a comment -

        It's really hard to reproduce the problem. So close it. If any scenario can be provided, we can reopen the JIRA

        Delos Dai made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Tim McConnell [ mcconne ] Delos Dai [ delos ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        605d 8h 25m 1 Delos Dai 30/Dec/09 09:19

          People

          • Assignee:
            Delos Dai
            Reporter:
            Tim McConnell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development