Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-7305

Update some dependecies due to security vulnerabilities

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Task
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • None
    • security
    • None

    Description

      After some security vulnerability testing we found some issues. To avoid it we need to update:

      Lucene: 6.6.2 -> 8.2.0

      Jackson-databind:  2.9.8 -> 2.10.0

      Apache Common Beanutils: 1.9.3 -> 1.9.4

      Jetty: 9.4.12.v20180830 -> 9.4.21.v20190926 

       

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            mkevo Mario Kevo
            mkevo Mario Kevo

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 7h 10m
                7h 10m

                Issue deployment