Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-5731

--hostname-for-client not working correclty

    XMLWordPrintableJSON

    Details

      Description

      When starting a server cluster on EC2 and --hostname-for-client set for locator and server then the locator does not return the client-bind-address.

      Locator and server were initially started with

      start locator --name=locator --port=41111 --properties-file=./gemfire.properties --initial-heap=256M --hostname-for-clients=ec2-12-345-678-90.compute-1.amazonaws.com
      
      start server --name=server1 --server-port=44666 --properties-file=./gemfire.properties --initial-heap=256M --start-rest-api=true --http-service-port=7676
      

      After some debugging the hostname-for-client on the server was also set to be the public IP address.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jjramos Juan Ramos
                Reporter:
                amurmann Alexander Murmann
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m