Details
-
Bug
-
Status: Closed
-
Major
-
Resolution: Fixed
-
None
-
None
-
None
Description
We have three properties that do not follow the JavaBean convention:
public interface FtpFile {
boolean hasReadPermission();
boolean hasWritePermission();
boolean hasDeletePermission();
...
}
They could be renamed as
public interface FtpFile {
boolean isReadable();
boolean isWritable();
boolean isRemovable();
...
}
Using the JavaBean convetion for properties allow interoperability with code that uses bean introspection to access to object classes.