Forrest
  1. Forrest
  2. FOR-984

validate-sitemap target fails relaxng validation on some JDK 1.6: missing datatypes

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8, 0.9
    • Fix Version/s: 0.9
    • Labels:
      None

      Description

      Doing 'forrest' fails at the validate-sitemap task. Missing the RELAX NG datatype library ...

      validate-sitemap:
      D:\apache-forrest-0.8rc\main\webapp\resources\schema\relaxng\sitemap-v06.rng:72:31:
      error: datatype library "http://www.w3.org/2001/XMLSchema-datatypes" not recognized

      People should be able to work around that by editing their forrest.properties configuration to expose the "forrest.validate.sitemap" property and set it to "false". Might need to do the same for the "forrest.validate.stylesheets" property.

      1. log.txt
        15 kB
        Schumarer

        Activity

        David Crossley added a comment - - edited
        That is working fine in Forrest-0.9-dev

        Please see the FAQ which describes two simple workarounds:
        1) As described above, and in the FAQ, set some validation properties to false.
         or ...
        2) Update your Forrest's copy of jing.jar

        http://forrest.apache.org/docs_0_90/faq.html#oldjing
        David Crossley made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        David Crossley added a comment -
        Fantastic. Thanks. Welcome to the new Jing.
        Thorsten Scherler added a comment -
        Environment : Guadalinex v5 (basado en ubuntu 8.04)

        java -version
        java version "1.6.0"
        Java(TM) SE Runtime Environment (build 1.6.0-b105)
        Java HotSpot(TM) Server VM (build 1.6.0-b105, mixed mode)
        ...

        forrest validate :
        ...
        validate-xdocs:
        Warning: Reference forrest.cp has not been set at runtime, but was found during
        build file parsing, attempting to resolve. Future versions of Ant may support
         referencing ids defined in non-executed targets.
        31 file(s) have been successfully validated.
        ...validated xdocs

        validate-skinconf:
        1 file(s) have been successfully validated.
        ...validated skinconf

        validate-sitemap:
        ...validated project sitemap

        validate-skinchoice:
        ...validated existence of skin 'pelt'

        BUILD SUCCESSFUL
        Total time: 8 seconds
        Cyriaque Dupoirieux added a comment -
        I have tested what David wanted :

        Environment : Windows XP

        java -version
        java version "1.6.0_07"
        Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
        Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)

        forrest validate :
        ...
        validate-xdocs:
        Warning: Reference forrest.cp has not been set at runtime, but was found during
        build file parsing, attempting to resolve. Future versions of Ant may support
         referencing ids defined in non-executed targets.
        31 file(s) have been successfully validated.
        ...validated xdocs

        validate-skinconf:
        1 file(s) have been successfully validated.
        ...validated skinconf

        validate-sitemap:
        ...validated project sitemap

        validate-skinchoice:
        ...validated existence of skin 'pelt'

        BUILD SUCCESSFUL
        Total time: 8 seconds
        David Crossley added a comment -
        Would someone on Java 6 please test the current Forrest trunk SVN.

        ]$ cd my-new-dir
        ]$ forrest seed
        ]$ forrest validate

        It should now get past the "validate-sitemap" stage.
        David Crossley added a comment -
        I see that James Clark has re-surfaced and commenced a project for Jing and other RELAX NG tools.
        http://code.google.com/p/jing-trang/ ... BSD license.

        I haven't tried yet (and not yet on Java 6 anyway) but updating our packaged version of Jing might help.
        David Crossley made changes -
        Description Hi,
        This problem is quite easy to reproduce. First, install Sun's JDK 1.6 (whatever version until 1.6.0_01-b06 ) define your %JAVA_HOME% on that JDK.

        When you seed a new projet, there is no problem and it works.

        When you do a "forrest run", it works too, but when you do a "forrest" it doesn't work anymore. I'll try to attach a full log.
        Doing 'forrest' fails at the validate-sitemap task. Missing the RELAX NG datatype library ...

        validate-sitemap:
        D:\apache-forrest-0.8rc\main\webapp\resources\schema\relaxng\sitemap-v06.rng:72:31:
        error: datatype library "http://www.w3.org/2001/XMLSchema-datatypes" not recognized

        People should be able to work around that by editing their forrest.properties configuration to expose the "forrest.validate.sitemap" property and set it to "false". Might need to do the same for the "forrest.validate.stylesheets" property.

        Summary Forrest doesn't work properly with Sun's JDK 1.6 validate-sitemap target fails relaxng validation on some JDK 1.6: missing datatypes
        David Crossley added a comment -
        Changed the Issue Summary from "Forrest doesn't work properly with Sun's JDK 1.6" to "validate-sitemap target fails relaxng validation on some JDK 1.6: missing datatypes". Also edited description.

        validate-sitemap:
        C:\devtools\apache-forrest-0.7\main\webapp\resources\schema\relaxng\sitemap-v06.rng:72:31: error: datatype library
        "http://www.w3.org/2001/XMLSchema-datatypes" not recognized
        David Crossley added a comment -
        I do not yet have Java 1.6 so cannot help debug this. Looking at the "log.txt" attachment from the issue reporter, it seems that this happens from our "validate-sitemap" Ant task for Jing. So it is not Forrest itself.

        People should be able to work around that by editing their forrest.properties configuration to expose the "forrest.validate.sitemap" property and set it to "false". Might need to do the same for the "forrest.validate.stylesheets" property.
        Jacob Brown added a comment - - edited
        I have the same issue after downloading apache-forrest-0.8 and running forrest on the 'seeded' directory. I am running Debian with java version "1.5.0" gij (GNU libgcj) version 4.2.1 (Debian 4.2.1-5). I was even able to successfully build the project with the GNU tools by typing 'build' from the 'forrest/main' directory. Here is some verbose output from running forrest.

        validate-sitemap:

        BUILD FAILED
        /home/jacob/apache-forrest-0.8/main/targets/validate.xml:158: java.lang.NullPointerException
           at org.apache.tools.ant.Task.perform(Task.java:373)
           at org.apache.tools.ant.Target.execute(Target.java:341)
           at org.apache.tools.ant.Target.performTasks(Target.java:369)
           at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
           at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
           at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
           at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
           at org.apache.tools.ant.Main.runBuild(Main.java:668)
           at org.apache.tools.ant.Main.startAnt(Main.java:187)
           at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
           at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
        Caused by: java.lang.NullPointerException
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader$Service$Loader2.getResources(libgcj.so.81)
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader$Service.<init>(libgcj.so.81)
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader.<init>(libgcj.so.81)
           at com.thaiopensource.relaxng.impl.SchemaReceiverImpl.installHandlers(Unknown Source)
           at com.thaiopensource.validate.auto.AutoSchemaReceiver$Handler.startElement(Unknown Source)
           at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
           at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
           at org.apache.xerces.impl.XMLNSDocumentScannerImpl$NSContentDispatcher.scanRootElementHook(Unknown Source)
           at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
           at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
           at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
           at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
           at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
           at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
           at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
           at com.thaiopensource.validate.auto.AutoSchemaReader.createSchema(Unknown Source)
           at com.thaiopensource.validate.ValidationDriver.loadSchema(Unknown Source)
           at com.thaiopensource.relaxng.util.JingTask.execute(Unknown Source)
           at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
           at org.apache.tools.ant.Task.perform(Task.java:364)
           ...10 more
        --- Nested Exception ---
        java.lang.NullPointerException
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader$Service$Loader2.getResources(libgcj.so.81)
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader$Service.<init>(libgcj.so.81)
           at org.relaxng.datatype.helpers.DatatypeLibraryLoader.<init>(libgcj.so.81)
           at com.thaiopensource.relaxng.impl.SchemaReceiverImpl.installHandlers(Unknown Source)
           at com.thaiopensource.validate.auto.AutoSchemaReceiver$Handler.startElement(Unknown Source)
           at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
           at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
           at org.apache.xerces.impl.XMLNSDocumentScannerImpl$NSContentDispatcher.scanRootElementHook(Unknown Source)
           at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
           at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
           at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
           at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
           at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
           at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
           at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
           at com.thaiopensource.validate.auto.AutoSchemaReader.createSchema(Unknown Source)
           at com.thaiopensource.validate.ValidationDriver.loadSchema(Unknown Source)
           at com.thaiopensource.relaxng.util.JingTask.execute(Unknown Source)
           at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
           at org.apache.tools.ant.Task.perform(Task.java:364)
           at org.apache.tools.ant.Target.execute(Target.java:341)
           at org.apache.tools.ant.Target.performTasks(Target.java:369)
           at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
           at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
           at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
           at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
           at org.apache.tools.ant.Main.runBuild(Main.java:668)
           at org.apache.tools.ant.Main.startAnt(Main.java:187)
           at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
           at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
        Thorsten Scherler added a comment -
        This bug only should appear in jdk => 1.6.

        Seeing that you use 1.5 on Fedora makes me wonder which JDK you are using, suns or other?
        Bjorn Agren added a comment -

        Hi

        any updates on this? I get the same issue when using java 1.5 on Fedora 7. I do a forrest seed, then to run "forrest run" is ok but "forrest" halts at validate-sitemap with the error

        ......./apache-forrest-0.8/main/targets/validate.xml:158 java.lang.NullPointerException.

        This happens with the install right from the distribution: build.sh generates the above warning Container.Until.compose.......



        Any help is very appreciated

        thanks

        /Bjorn
        Cyriaque Dupoirieux added a comment -
        I have the following warning (build.sh) with the java 1.5.0_11 on Mandriva Linux Free 2007 :

        init:

              --------------------------------------------------------------

              Using Apache Ant version 1.6.5 compiled on May 16 2006
              Build file /home/windchill/Desktop/forrest/main/build.xml
              Use 'build.[sh|bat] -projecthelp' to see other options.
              Build system home /home/windchill/Desktop/forrest/tools/ant
              Build number 1
              Project Name Forrest build file
              Java Version 1.5
              Timestamp 200704170207
              This is: apache-forrest 0.8

              --------------------------------------------------------------
            

        compile:
        Created dir: /home/windchill/Desktop/forrest/build/classes
        Compiling 32 source files to /home/windchill/Desktop/forrest/build/classes
        /home/windchill/Desktop/forrest/main/java/org/apache/forrest/locationmap/lm/LocationMap.java:256: warning: [deprecation] compose(java.lang.Object,org.apache.avalon.framework.component.ComponentManager) in org.apache.avalon.framework.container.ContainerUtil has been deprecated
                ContainerUtil.compose(context, new WrapperComponentManager(m_manager));
                             ^
        Note: Some input files use unchecked or unsafe operations.
        Note: Recompile with -Xlint:unchecked for details.
        1 warning

        I think this may help, some APIs are deprecated in the 1.5 so they should not be used with 1.6...
        David Crossley made changes -
        Affects Version/s 0.9 [ 12310041 ]
        Fix Version/s 0.9 [ 12310041 ]
        Schumarer made changes -
        Field Original Value New Value
        Attachment log.txt [ 12355436 ]
        Schumarer added a comment -
        This has been tested on Windows SP2 with java 1.6.0_01 (latest version)
        Schumarer created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Schumarer
          • Votes:
            3 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development