Fop
  1. Fop
  2. FOP-2023

[PATCH] smiley glyph not displayed when using single-byte encoding mode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Component/s: font/unqualified
    • Labels:
      None
    • Environment:
      Operating System: Linux
      Platform: PC
    • External issue ID:
      52655

      Description

      The attached patch fixes an issue with fonts with single-byte encoding mode.

      To confirm the issue run the included test case (bug.fo and fop.xconf supplied).

      The current and post-fix output (ps and pdf) is also included.

      1. single_byte_encoding.tar.gz
        318 kB
        Luis Bernardo
      2. fix.patch
        6 kB
        Luis Bernardo

        Activity

        Glenn Adams made changes -
        Field Original Value New Value
        Affects Version/s trunk [ 12323672 ]
        Affects Version/s all [ 12323671 ]
        Glenn Adams added a comment -

        batch transition to closed; if someone wishes to restore one of these to resolved in order to perform a verification step, then feel free to do so

        Chris Bowditch added a comment -

        Thanks Vincent. No biggie, Luis has filed it now so we are covered.

        Vincent Hennebert added a comment -

        (In reply to comment #5)
        > Vincent,
        >
        > Did you miss my comment about ICLA? Luis really needs to submit an ICLA because
        > he has submitted a few patches now. You ought to have waited until the ICLA was
        > filed before committing this patch.
        >
        > Thanks,
        >
        > Chris

        Sorry, looks like I misunderstood the intent. I thought this patch was still small enough to be committed without ICLA, but that from now on the ICLA would be necessary.

        My apologies,
        Vincent

        Luis Bernardo added a comment -

        I faxed it this morning.
        Luis

        Chris Bowditch added a comment -

        Vincent,

        Did you miss my comment about ICLA? Luis really needs to submit an ICLA because he has submitted a few patches now. You ought to have waited until the ICLA was filed before committing this patch.

        Thanks,

        Chris

        Vincent Hennebert added a comment -

        Patch applied in rev. 1244656:
        http://svn.apache.org/viewvc?revision=1244656&view=revision

        Thanks!
        Vincent

        Chris Bowditch added a comment -

        Hi Luis,

        Thanks for your patch. Since you've submitted a few patches now, can you complete the ICLA as described in [1] and fax to the number on the agreement?

        Thanks,

        Chris

        [1] http://www.apache.org/licenses/

        Luis Bernardo added a comment -

        The issue is for instance visible when using arial.ttf with encoding-mode="single-byte". Try to produce PostScript that outputs the smiley (☺ going the IF -> PS route, or inside SVG when going the FO -> PS route. The smiley glyph will be replaced by a box.

        Luis Bernardo added a comment -

        Attachment single_byte_encoding.tar.gz has been added with description: test case and output

        Luis Bernardo added a comment -

        included test case

        Luis Bernardo created issue -
        Luis Bernardo added a comment -

        Attachment fix.patch has been added with description: patch


          People

          • Assignee:
            fop-dev
            Reporter:
            Luis Bernardo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development