Uploaded image for project: 'FOP'
  1. FOP
  2. FOP-1656

Table in marker gets duplicated at each marker retrieval

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Component/s: layout/unqualified
    • Labels:
      None
    • Environment:
      Operating System: Windows XP
      Platform: PC
    • External issue ID:
      47101

      Description

      if i use table in a Region Before or a Region after, table is duplicated. it seems table is multiplicated by the page number : 2 table on page 2, 3 on page 3, etc.

      it was not the case with previous version.

      i have joined a FO file to reproduce the bug and the resulting PDF.

      1. fop_bug.zip
        19 kB
        Joseph Poidevin
      2. table-duplicated-in-marker.fo
        3 kB
        Vincent Hennebert

        Activity

        ptitelfe@gmail.com Joseph Poidevin added a comment -

        Attachment fop_bug.zip has been added with description: fo file and resulting pdf

        vhennebert Vincent Hennebert added a comment -

        Thank you for your bug report. I attach a simplified FO file that can be used for debugging. Not sure what is the reason for the duplication of the table though.

        vhennebert Vincent Hennebert added a comment -

        Attachment table-duplicated-in-marker.fo has been added with description: Simplified FO file showing the problem

        adelmelle@apache.org Andreas L. Delmelle added a comment -

        (In reply to comment #1)
        > Created an attachment (id=23623) [details]
        > Simplified FO file showing the problem
        >
        > Thank you for your bug report. I attach a simplified FO file that can be used
        > for debugging. Not sure what is the reason for the duplication of the table
        > though.

        I did a quick check here, but haven't found out what the exact cause is either.
        One interesting thing I did notice so far: it is not the table that is duplicated, but the table-cell. On the first page, I get only one call to TableCellLM. On the second page, I get two, made by the same RowGroupLM. The table-body on the second page has its rowGroups set to 2...

        adelmelle@apache.org Andreas L. Delmelle added a comment -


        Most likely cause: when cloning the table-body upon each marker-retrieval, it does not go deep enough. Some member (can't tell yet which one exactly) is copied as a reference, while it should, in fact, be an entirely separate instance. Overriding clone() in the corresponding FONode type (TablePart?) to add specific behavior may just be enough to fix this...

        vhennebert Vincent Hennebert added a comment -
        gadams Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed


          People

          • Assignee:
            fop-dev@xmlgraphics.apache.org fop-dev
            Reporter:
            ptitelfe@gmail.com Joseph Poidevin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development