Fop
  1. Fop
  2. FOP-1570

[PATCH] regression: "descender" sign inverted in font metrics for PFM (distorted line spacing for fo:inline)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 0.95
    • Fix Version/s: None
    • Component/s: fonts
    • Labels:
    • Environment:
      Operating System: Linux
      Platform: PC
    • External issue ID:
      45734

      Description

      When we switched to FOP 0.95 and re-ran PFMReader on our .pfm files, the line spacing suddenly became distorted on lines that contained fo:inline tags that used a different font-family.

      It turned out that the font metrics produced by FOP 0.95 have an inverted sign for the descender value. When inverting it again (i.e. remove the minus sign in the font metrics xml), all was well again.

      It seems that this is due to changes to PFMFile in r56078 for bug#43089. Our fix was to invert the sign in PFMReader on producing the metrics file, since the sign inversion in PFMFile seems to be needed.

        Activity

        J added a comment -

        Attachment PFMReader.svnpatch has been added with description: Patch for PFMReader

        Jeremias Maerki added a comment -

        Thanks! Patch applied to FOP Trunk:
        http://svn.apache.org/viewvc?rev=693781&view=rev

        Please note that with 0.95, the font metrics files are no longer necessary. You can simply forget about the PFMReader and the TTFReader. Please see the following page for details:
        http://xmlgraphics.apache.org/fop/0.95/fonts.html#basics

        Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed


          People

          • Assignee:
            fop-dev
            Reporter:
            J
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development