FOP
  1. FOP
  2. FOP-1456

NullPointerException throw if there is no fo:root

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 0.94
    • Fix Version/s: None
    • Component/s: fo/unqualified
    • Labels:
      None
    • Environment:
      Operating System: All
      Platform: All
    • External issue ID:
      43910

      Description

      in AreaTreeHandler, if no fo:root was found in document (which can arise from
      time to time when you use fo together with xslt), the endDocument() method
      throws a nullpointerexception instead of making clean fallback (either generate
      empty document or throw a SAXException). Because NullPointerException is quite
      anonymous error, it makes it difficult for caller to properly catch it and
      handle it in calling code.

      Please note javadoc of endDocument states that it "throws SAXException if there
      is some error". So this probably should be throwing a SAXException("no fo:root
      found in document")

      Caused by: java.lang.NullPointerException
      at org.apache.fop.area.AreaTreeHandler.endDocument(AreaTreeHandler.java:264)
      at org.apache.fop.fo.FOTreeBuilder.endDocument(FOTreeBuilder.java:171)
      at net.sf.saxon.event.ContentHandlerProxy.close(ContentHandlerProxy.java:255)
      at net.sf.saxon.event.ImplicitResultChecker.close(ImplicitResultChecker.java:69)
      at net.sf.saxon.event.ProxyReceiver.close(ProxyReceiver.java:86)
      at
      net.sf.saxon.event.ComplexContentOutputter.close(ComplexContentOutputter.java:458)
      at net.sf.saxon.Controller.transformDocument(Controller.java:1655)
      at net.sf.saxon.Controller.transform(Controller.java:1438)

      1. patch.43910
        2 kB
        David Delbecq

        Activity

        David Delbecq added a comment -

        Submited patch that properly solves the issue. fop creates correct pdf that has
        no page in it (only metadatas)

        David Delbecq added a comment -

        Attachment patch.43910 has been added with description: Patch that solves the issue

        Jeremias Maerki added a comment -

        Patch applied. Thanks.
        http://svn.apache.org/viewvc?rev=596600&view=rev

        I couldn't reproduce the NPE but the change makes sense if it helps you.

        Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed


          People

          • Assignee:
            fop-dev
            Reporter:
            David Delbecq
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development