FOP
  1. FOP
  2. FOP-1446

Problems with empty table-cells

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 0.94
    • Fix Version/s: None
    • Component/s: layout/unqualified
    • Labels:
      None
    • Environment:
      Operating System: other
      Platform: Other
    • External issue ID:
      43766

      Description

      Tables spanning multiple pages sometimes show an extra row / extra border at the
      end of the page. See attached example.
      The problem seems linked to the presence of empty cells.

      1. test.fo
        61 kB
        Herv
      2. test.pdf
        13 kB
        Herv

        Activity

        Herv added a comment -

        Attachment test.fo has been added with description: The FO file

        Herv added a comment -

        Attachment test.pdf has been added with description: Resulting PDF

        Vincent Hennebert added a comment -

        Thanks for reporting the bug. Funny that the same problem has been reported
        several times recently. Looks like the issue is more urgent than I thought.

        Other references:
        http://mail-archives.apache.org/mod_mbox/xmlgraphics-fop-users/200710.mbox/%3c26DB90BE942D3942ABCB5D8B82BD8B9331A9D4@exchange01.trax.aero%3e
        http://mail-archives.apache.org/mod_mbox/xmlgraphics-fop-users/200710.mbox/%3cF0BC0D1F785C0145B6BA3DFE82BCEE0406F0CE6A@LNGDAYEXCP01VA.legal.regn.net%3e

        Summary: when a row contains an empty cell, all of the break elements generated
        for this row have a 900 penalty, leading to all sorts of strange results.

        Vincent Hennebert added a comment -

        Should be fixed in revision 596390

        Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed


          People

          • Assignee:
            fop-dev
            Reporter:
            Herv
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development