FOP
  1. FOP
  2. FOP-1378

fo:retrieve-marker missing PCDATA from fo:marker

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 0.93
    • Fix Version/s: None
    • Component/s: layout/unqualified
    • Labels:
      None
    • Environment:
      Operating System: All
      Platform: PC
    • External issue ID:
      42705

      Description

      If fo:marker consists of PCDATA + fo:inline, when processing an
      fo:retrieve-marker the PCDATA is missing.

      1. BUG-2-retrieve-marker.fo
        1 kB
        Guillaume Levrero
      2. BUG-2-retrieve-marker.pdf
        6 kB
        Guillaume Levrero
      3. BUG-2-retrieve-marker.pdf
        6 kB
        Guillaume Levrero

        Activity

        Guillaume Levrero created issue -
        Hide
        Guillaume Levrero added a comment -

        Attachment BUG-2-retrieve-marker.pdf has been added with description: FO to reproduce problem

        Show
        Guillaume Levrero added a comment - Attachment BUG-2-retrieve-marker.pdf has been added with description: FO to reproduce problem
        Hide
        Guillaume Levrero added a comment -

        Attachment BUG-2-retrieve-marker.pdf has been added with description: PDF output

        Show
        Guillaume Levrero added a comment - Attachment BUG-2-retrieve-marker.pdf has been added with description: PDF output
        Hide
        Andreas L. Delmelle added a comment -

        Confirmed... I managed to reproduce it (in spite of the missing FO; you attached the PDF twice

        Still looking for a fix, but as a possible workaround, I noticed the problem only occurs if the PCDATA node
        starts with a linefeed. Try to avoid:

        <fo:marker>
        Text

        and use:

        <fo:marker>Text

        Show
        Andreas L. Delmelle added a comment - Confirmed... I managed to reproduce it (in spite of the missing FO; you attached the PDF twice Still looking for a fix, but as a possible workaround, I noticed the problem only occurs if the PCDATA node starts with a linefeed. Try to avoid: <fo:marker> Text and use: <fo:marker>Text
        Hide
        Guillaume Levrero added a comment -

        Attachment BUG-2-retrieve-marker.fo has been added with description: FO to reproduce problem

        Show
        Guillaume Levrero added a comment - Attachment BUG-2-retrieve-marker.fo has been added with description: FO to reproduce problem
        Hide
        Andreas L. Delmelle added a comment -

        Fixed in FOP Trunk.
        see: http://svn.apache.org/viewvc?rev=576095&view=rev

        Thanks for reporting!

        Show
        Andreas L. Delmelle added a comment - Fixed in FOP Trunk. see: http://svn.apache.org/viewvc?rev=576095&view=rev Thanks for reporting!
        Hide
        Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed

        Show
        Glenn Adams added a comment - batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed

          People

          • Assignee:
            fop-dev
            Reporter:
            Guillaume Levrero
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development