Flume
  1. Flume
  2. FLUME-759

Regression due to avro 1.5.2 upgrade

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v0.9.5
    • Fix Version/s: v0.9.5
    • Component/s: None
    • Labels:
      None

      Description

      I've spent some time cleaning up builds and noticed that the version of maven sure fire/jenkins we were using failed to point out that the log4j appender tests have been failing since upgrading to avro 1.5.2 (FLUME-741).

      This can be triggered by going into the flume-log4j-appender dir and doing a 'mvn test' in there. Test should hang or time out after 8 minute or so.

      1. FLUME-759.patch
        0.9 kB
        Tom White
      2. FLUME-759.patch
        2 kB
        Tom White
      3. FLUME-759.patch
        2 kB
        Tom White

        Activity

        Hide
        Jonathan Hsieh added a comment -

        FLUME-755 (upgrading to avro 1.5.3) did not fix this problem.

        Show
        Jonathan Hsieh added a comment - FLUME-755 (upgrading to avro 1.5.3) did not fix this problem.
        Hide
        Tom White added a comment -

        This patch plus AVRO-884 fixes the problem.

        Show
        Tom White added a comment - This patch plus AVRO-884 fixes the problem.
        Hide
        Tom White added a comment -

        This patch shows that using Avro 1.5.4 (not yet released but in the staging repo) fixes the test (TestFlumeLog4jAvroAppender).

        Note that this is not ready to be committed yet - we need to wait for Avro 1.5.4 to be released, and the staging repositiory should not be added to the POM.

        Show
        Tom White added a comment - This patch shows that using Avro 1.5.4 (not yet released but in the staging repo) fixes the test (TestFlumeLog4jAvroAppender). Note that this is not ready to be committed yet - we need to wait for Avro 1.5.4 to be released, and the staging repositiory should not be added to the POM.
        Hide
        Tom White added a comment -

        Here's a new patch now that Avro 1.5.4 is in Maven central. I also fixed a couple of places where the 1.5.3 Avro Maven plugin was being used.

        Show
        Tom White added a comment - Here's a new patch now that Avro 1.5.4 is in Maven central. I also fixed a couple of places where the 1.5.3 Avro Maven plugin was being used.
        Hide
        Jonathan Hsieh added a comment -

        committed. Thanks tom!

        Show
        Jonathan Hsieh added a comment - committed. Thanks tom!

          People

          • Assignee:
            Tom White
            Reporter:
            Jonathan Hsieh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development