Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-700

Make build explicitly depend on antlr-runtime

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.4
    • Fix Version/s: 0.9.5
    • Component/s: Build
    • Labels:
      None

      Description

      The build previously used an implicit dependency on antlr-runtime. If the version dependency plugin is used this can cause situations where older versions win out. To fix this we add an explicit dependency to the build which ensure that the version flume requires wins.

        Attachments

          Activity

            People

            • Assignee:
              jmhsieh Jonathan Hsieh
              Reporter:
              jmhsieh Jonathan Hsieh
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: