Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.8.0
    • Component/s: None
    • Labels:
      None

      Description

      We should move to Java 8 as a minimum requirement.

      1. Java 7 is EOL'ed http://www.oracle.com/technetwork/java/eol-135779.html.
      2. Many projects are adopting java 8 as a minimum requirement, for instance:

      The attached patch was tested on Ubuntu 16.04 with openjdk version "1.8.0_91".
      All unit tests, except for the known flaky ones, successfully passed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                liorze Lior Zeno
                Reporter:
                liorze Lior Zeno
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: