Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2921

Support Elasticsearch 2.0+

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Patch Available
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: Sinks+Sources
    • Labels:
      None

      Description

      Elasticsearch sink supports an ancient version of ES. We should make the sink work with newer versions of Elasticsearch.

      I attached a patch for that. Please note that this involves upgrading netty and guava.

        Attachments

        1. FLUME-2921-0.patch
          41 kB
          Lior Zeno
        2. FLUME-2921-1.patch
          23 kB
          Lior Zeno

          Issue Links

            Activity

              People

              • Assignee:
                liorze Lior Zeno
                Reporter:
                liorze Lior Zeno
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: