Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Implemented
    • Affects Version/s: None
    • Fix Version/s: 1.6.0, 1.5.2
    • Component/s: Sinks+Sources
    • Labels:
      None

      Description

      When kite dataset was introduced by Flume 1.5.0, the latest kite version was 0.12.0 at that time. Currently 0.12.0 can not be found in Maven repository, only 0.15.0 and later are provided. I guess 0.12.0 is deprecated and it can be only found in Cloudera repository https://repository.cloudera.com/cloudera/cloudera-repos/org/kitesdk/

      Considering that Kite 0.17.1 includes new features http://kitesdk.org/docs/0.17.1/release-notes, shall we upgrade kite to 0.17.1?

        Activity

        Hide
        water Xiang Li added a comment -

        The trunk has picked up kite 1.0.0

        Show
        water Xiang Li added a comment - The trunk has picked up kite 1.0.0
        Hide
        water Xiang Li added a comment -

        Hi Hari,

        Thanks! I verified in trunk just now, kite 1.0.0 has been picked up. Great!
        Just leave a note here --> http://kitesdk.org/docs/1.0.0/release-notes

        Show
        water Xiang Li added a comment - Hi Hari, Thanks! I verified in trunk just now, kite 1.0.0 has been picked up. Great! Just leave a note here --> http://kitesdk.org/docs/1.0.0/release-notes
        Hide
        hshreedharan Hari Shreedharan added a comment -

        We actually already upgraded trunk. Can you please verify?

        Show
        hshreedharan Hari Shreedharan added a comment - We actually already upgraded trunk. Can you please verify?
        Hide
        water Xiang Li added a comment -

        2 modules of Flume use kite, but only Kite dataset sink is affected by the Kite upgrade
        (1) Kite dataset sink.
        kite-data-core is used the as the dependency.
        Compile error. DataSink.java and TestDataSink.java are to be updated to adapt to the class and API changes from 0.12.0 to 0.17.1.
        (2) Morphline solr sink.
        kite-morphlines-all and kite-morphlines-solr-core are used as the dependencies.
        No UT failure when using 0.17.1.

        Show
        water Xiang Li added a comment - 2 modules of Flume use kite, but only Kite dataset sink is affected by the Kite upgrade (1) Kite dataset sink. kite-data-core is used the as the dependency. Compile error. DataSink.java and TestDataSink.java are to be updated to adapt to the class and API changes from 0.12.0 to 0.17.1. (2) Morphline solr sink. kite-morphlines-all and kite-morphlines-solr-core are used as the dependencies. No UT failure when using 0.17.1.

          People

          • Assignee:
            Unassigned
            Reporter:
            water Xiang Li
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development