Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2098

Make Solr sink depend on the CDK version of morphlines

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: Build
    • Labels:
      None

      Description

      Now that Morphlines have migrated to CDK, it would make sense to update dependencies to point there.

      1. extra.patch.txt
        0.4 kB
        Roman Shaposhnik
      2. FLUME-2098.patch.txt
        2 kB
        Roman Shaposhnik

        Activity

        Hide
        rvs Roman Shaposhnik added a comment -

        Attaching an extra patch that gets rid of the SNAPSHOT dependency that is present in CDK itself.

        Show
        rvs Roman Shaposhnik added a comment - Attaching an extra patch that gets rid of the SNAPSHOT dependency that is present in CDK itself.
        Hide
        mpercy Mike Percy added a comment -

        +1. Good catch Roman, running unit tests now and I will commit this if everything passes.

        Show
        mpercy Mike Percy added a comment - +1. Good catch Roman, running unit tests now and I will commit this if everything passes.
        Hide
        whoschek wolfgang hoschek added a comment -

        Actually, the version in Roman's extra patch should be 4.3.0 rather than 4.3.1

        Show
        whoschek wolfgang hoschek added a comment - Actually, the version in Roman's extra patch should be 4.3.0 rather than 4.3.1
        Hide
        mpercy Mike Percy added a comment -

        Pushed to trunk and flume-1.4 branches. Thanks Roman!

        Show
        mpercy Mike Percy added a comment - Pushed to trunk and flume-1.4 branches. Thanks Roman!
        Hide
        mpercy Mike Percy added a comment -

        Wolfgang, I will bump it down to 4.3.0 if you think there is a potential problem with this.

        Show
        mpercy Mike Percy added a comment - Wolfgang, I will bump it down to 4.3.0 if you think there is a potential problem with this.
        Hide
        whoschek wolfgang hoschek added a comment -

        We haven't tested with solr 4.3.1. so going to solr 4.3.0 is a safer bet at this time.

        Show
        whoschek wolfgang hoschek added a comment - We haven't tested with solr 4.3.1. so going to solr 4.3.0 is a safer bet at this time.
        Hide
        hudson Hudson added a comment -

        Integrated in flume-trunk #441 (See https://builds.apache.org/job/flume-trunk/441/)
        FLUME-2098. Make Solr sink depend on the CDK version of morphlines. (Revision 53649f06fef8852c28a87376cb1bfe365b4df8d8)

        Result = FAILURE
        mpercy : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=53649f06fef8852c28a87376cb1bfe365b4df8d8
        Files :

        • pom.xml
        • flume-ng-sinks/flume-ng-morphline-solr-sink/pom.xml
        Show
        hudson Hudson added a comment - Integrated in flume-trunk #441 (See https://builds.apache.org/job/flume-trunk/441/ ) FLUME-2098 . Make Solr sink depend on the CDK version of morphlines. (Revision 53649f06fef8852c28a87376cb1bfe365b4df8d8) Result = FAILURE mpercy : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=53649f06fef8852c28a87376cb1bfe365b4df8d8 Files : pom.xml flume-ng-sinks/flume-ng-morphline-solr-sink/pom.xml
        Hide
        mpercy Mike Percy added a comment -

        Wolfgang, since you are the author of the Morphline Solr Sink I agree we should depend on the version you tested against. I just pushed the change to bump the version down to 4.3.0. Thanks!

        Show
        mpercy Mike Percy added a comment - Wolfgang, since you are the author of the Morphline Solr Sink I agree we should depend on the version you tested against. I just pushed the change to bump the version down to 4.3.0. Thanks!
        Hide
        hudson Hudson added a comment -

        Integrated in flume-trunk #443 (See https://builds.apache.org/job/flume-trunk/443/)
        FLUME-2098. Solr version be 4.3.0. (Revision 5e53866c30388cb9abc8dc33307827f9e57f642b)

        Result = UNSTABLE
        mpercy : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=5e53866c30388cb9abc8dc33307827f9e57f642b
        Files :

        • pom.xml
        Show
        hudson Hudson added a comment - Integrated in flume-trunk #443 (See https://builds.apache.org/job/flume-trunk/443/ ) FLUME-2098 . Solr version be 4.3.0. (Revision 5e53866c30388cb9abc8dc33307827f9e57f642b) Result = UNSTABLE mpercy : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=5e53866c30388cb9abc8dc33307827f9e57f642b Files : pom.xml

          People

          • Assignee:
            rvs Roman Shaposhnik
            Reporter:
            rvs Roman Shaposhnik
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development